summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/xwax/Manifest1
-rw-r--r--media-sound/xwax/metadata.xml1
-rw-r--r--media-sound/xwax/xwax-1.7.ebuild85
3 files changed, 86 insertions, 1 deletions
diff --git a/media-sound/xwax/Manifest b/media-sound/xwax/Manifest
index 6609619d22d2..30e8799c89f9 100644
--- a/media-sound/xwax/Manifest
+++ b/media-sound/xwax/Manifest
@@ -1 +1,2 @@
DIST xwax-1.6.tar.gz 79452 BLAKE2B 3cefded6fd39435d92ca07458048910e5e95169562c9dec17cd1411c992ca864124f3155b1a8a9313c86cfee01fe79d72a5c5bed9963b1740a1d4e89e9e249e9 SHA512 710a53a1b056bf6850a668a1f267b91664d5629998e6ee2d4853aa57d1ab351dd782716272ed4a4858168c0ac9f5c7d2e1fe0a8b330e26775677e1eb54249015
+DIST xwax-1.7.tar.gz 80745 BLAKE2B b431951651b66899b5bcceadfadc546c564123e47632aa9b395c26d706fc37cda4b5bf4f8695538e1a5e2bb0a690f125ca89705259d11df580f6a833e5d114b6 SHA512 ab0fcaf32f1fd1d6b38323095524f1932a067a3d04d40e4b043993e360411fed0c4b78bb71662581b438cb1e3005bc21659db4521a6ec704994b2e8e1b7e62d4
diff --git a/media-sound/xwax/metadata.xml b/media-sound/xwax/metadata.xml
index 762283d3c0c5..aa4bd1f8dd50 100644
--- a/media-sound/xwax/metadata.xml
+++ b/media-sound/xwax/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="alsa">Adds support for ALSA audio input/output.</flag>
- <flag name="jack">Adds support for audio input/output via the JACK Audio Connection Kit.</flag>
<flag name="oss">Adds support for OSS (open sound system) audio input/output.</flag>
<flag name="cdda">Sets runtime dependencies to support decoding audio from a compact disc.</flag>
<flag name="mp3">Sets runtime dependencies to support decoding MP3 audio.</flag>
diff --git a/media-sound/xwax/xwax-1.7.ebuild b/media-sound/xwax/xwax-1.7.ebuild
new file mode 100644
index 000000000000..edf6f44c7c6d
--- /dev/null
+++ b/media-sound/xwax/xwax-1.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs user
+
+DESCRIPTION="Digital vinyl emulation software"
+HOMEPAGE="https://xwax.org/"
+SRC_URI="https://xwax.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa jack oss cdda mp3 +fallback"
+
+REQUIRED_USE="|| ( cdda mp3 fallback )
+ || ( alsa jack oss )"
+
+DEPEND="
+ media-fonts/dejavu
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ sys-libs/glibc
+ sys-libs/pam
+ alsa? ( media-libs/alsa-lib )
+ cdda? ( media-sound/cdparanoia )
+ fallback? ( media-video/ffmpeg )
+ jack? ( virtual/jack )
+ mp3? ( media-sound/mpg123 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README CHANGES )
+
+src_prepare() {
+ default
+ # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
+ # the Makefile
+ # Also remove the dependency on the .version target so we don't need
+ # git just to build
+ sed -i -e 's/\(^\(LD\|C\)FLAGS.*\)-O[0-9]\(.*\)/\1\3/g' \
+ -e 's/^xwax\.o:.*\.version//' \
+ Makefile || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ --prefix "${EROOT}/usr" \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable oss)
+}
+
+src_compile() {
+ # EXECDIR is the default directory in which xwax will look for
+ # the 'xwax-import' and 'xwax-scan' scripts
+ emake EXECDIR="\$(BINDIR)" VERSION="${PV}" xwax
+}
+
+pkg_preinst() {
+ enewgroup ${PN}
+}
+
+src_install() {
+ # This is easier than setting all the environment variables
+ # needed, running the sed script required to get the man directory
+ # correct, and removing the GPL-2 after a 'make install' run
+ dobin xwax
+ newbin scan xwax-scan
+ newbin import xwax-import
+ doman xwax.1
+
+ dodoc ${DOCS}
+
+ insinto "/etc/security/limits.d"
+ newins "${FILESDIR}/xwax-etc-security-limits.conf" xwax.conf
+}
+
+pkg_postinst() {
+ elog "Be sure to add any users that will be using ${PN} to the"
+ elog "\"${PN}\" group. Doing so will allow processes that user"
+ elog "runs to request realtime priority."
+}