summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch25
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.18.0-r4.ebuild74
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index c94006d00ca3..fdd656fe9063 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1,2 +1 @@
-DIST vdirsyncer-0.18.0.tar.gz 115125 BLAKE2B d81bb9b51658d16a3b9ea044846561a1ce2dac3a839d7e0a165f0136069fcd0716525ab2b908be7cafed60846a1aed6fd72aa1d31fc2a38dbe6de8d0e6585226 SHA512 7fb3d0f7d982d8390d278de1a620231e6ead1ec64057c5dbac98dcff491fa3e6b9ed8ba953995458e393aab73b0b9ab8ba14010e06f90a04d8ee2c28c7c7fbfd
DIST vdirsyncer-0.19.2.tar.gz 123389 BLAKE2B 35cf5e52f669307c7bc545404135bfb5ded3ca6a1b151735ddacd73835054a2e0ab518201ad206929ca845c2a2828c025a918bba54b739db3fa0a8e4e9f5de33 SHA512 056c58011d0a054a8cc215e9eabc706dfffb7d38deab5ae47311565b3bdb6de7a4772e97a0a50cdce33c82b09d559f1ec9cf9c84746553badf1d25791c7e08ce
diff --git a/dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch b/dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch
deleted file mode 100644
index d7e1d537ce49..000000000000
--- a/dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Avoid pytest-cov involvement:
-
-https://dev.gentoo.org/~mgorny/python-guide/pytest.html#avoiding-dependencies-on-other-pytest-plugins
-
-Signed-Off-By: John Helmert III <ajak@gentoo.org>
-
-diff --git a/setup.cfg b/setup.cfg
-index 2428e44..117f237 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -1,14 +1,6 @@
- [wheel]
- universal = 1
-
--[tool:pytest]
--addopts =
-- --tb=short
-- --cov-config .coveragerc
-- --cov=vdirsyncer
-- --cov-report=term-missing
-- --no-cov-on-fail
--
- [flake8]
- application-import-names = tests,vdirsyncer
- extend-ignore =
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.18.0-r4.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.18.0-r4.ebuild
deleted file mode 100644
index fb656166c00a..000000000000
--- a/dev-python/vdirsyncer/vdirsyncer-0.18.0-r4.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 pypi systemd
-
-DESCRIPTION="Synchronize calendars and contacts"
-HOMEPAGE="
- https://github.com/pimutils/vdirsyncer/
- https://pypi.org/project/vdirsyncer/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
- >=dev-python/click-threading-0.5[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/atomicwrites[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.18.0-no-cov.patch"
-)
-
-DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin click-log
- # https://github.com/pimutils/vdirsyncer/commit/ea640001d0ad6e56369102e02b949c865c48726f
- sed -i -e '/click-log/s:, <0.4.0::' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # skip tests needing servers running
- local -x DAV_SERVER=skip
- local -x REMOTESTORAGE_SERVER=skip
- # pytest dies hard if the envvars do not have any value...
- local -x CI=false
- local -x DETERMINISTIC_TESTS=false
-
- local EPYTEST_DESELECT=(
- # test CA is too weak for modern python
- tests/system/utils/test_main.py::test_request_ssl
- tests/system/utils/test_main.py::test_request_ssl_fingerprints
- )
-
- epytest
-}
-
-src_install() {
- distutils-r1_src_install
-
- systemd_douserunit contrib/vdirsyncer.{service,timer}
-}