summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/numad/files/0001-numad_log-fix-buffer-overflow.patch25
-rw-r--r--sys-process/numad/numad-0.5_p20180531-r2.ebuild (renamed from sys-process/numad/numad-0.5_p20180531-r1.ebuild)10
2 files changed, 29 insertions, 6 deletions
diff --git a/sys-process/numad/files/0001-numad_log-fix-buffer-overflow.patch b/sys-process/numad/files/0001-numad_log-fix-buffer-overflow.patch
new file mode 100644
index 000000000000..c67d58192169
--- /dev/null
+++ b/sys-process/numad/files/0001-numad_log-fix-buffer-overflow.patch
@@ -0,0 +1,25 @@
+From a9e6f292f4ce9443ee95c77c60dd8da68d0db7e9 Mon Sep 17 00:00:00 2001
+From: Lukas Nykryn <lnykryn@redhat.com>
+Date: Wed, 6 Sep 2023 12:27:47 +0200
+Subject: [PATCH] numad_log: fix buffer overflow
+
+---
+ numad.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/numad.c b/numad.c
+index 4c85486..2923842 100644
+--- a/numad.c
++++ b/numad.c
+@@ -153,7 +153,7 @@ void numad_log(int level, const char *fmt, ...) {
+ *p++ = ' ';
+ va_list ap;
+ va_start(ap, fmt);
+- vsnprintf(p, BUF_SIZE, fmt, ap);
++ vsnprintf(p, BUF_SIZE - strlen(buf) , fmt, ap);
+ va_end(ap);
+ fprintf(log_fs, "%s", buf);
+ fflush(log_fs);
+--
+2.39.2
+
diff --git a/sys-process/numad/numad-0.5_p20180531-r1.ebuild b/sys-process/numad/numad-0.5_p20180531-r2.ebuild
index 229cae6f6556..ce503112f43e 100644
--- a/sys-process/numad/numad-0.5_p20180531-r1.ebuild
+++ b/sys-process/numad/numad-0.5_p20180531-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic linux-info systemd toolchain-funcs
+inherit linux-info systemd toolchain-funcs
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://pagure.io/numad.git"
@@ -31,15 +31,13 @@ PATCHES=(
# from debian/ubuntu: https://sources.debian.org/patches/numad
"${FILESDIR}/${PN}-0.5-fix-build-for-no-NR-migrate-pages.patch"
+
+ # from fedora: https://src.fedoraproject.org/rpms/numad/c/b9fdb5b1b09611ba164c04cd994e5e9ddf7fb8f4
+ "${FILESDIR}/0001-numad_log-fix-buffer-overflow.patch"
)
src_configure() {
tc-export AR CC RANLIB
-
- # FIXME: https://bugs.gentoo.org/890985
- # temp workaround
- filter-flags -D_FORTIFY_SOURCE=3
- append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
}
src_compile() {