summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-kids/lletters/files/lletters-0.1.95-clang16.patch56
-rw-r--r--games-kids/lletters/lletters-0.1.95-r5.ebuild (renamed from games-kids/lletters/lletters-0.1.95-r4.ebuild)24
2 files changed, 69 insertions, 11 deletions
diff --git a/games-kids/lletters/files/lletters-0.1.95-clang16.patch b/games-kids/lletters/files/lletters-0.1.95-clang16.patch
new file mode 100644
index 000000000000..8fb6591dd136
--- /dev/null
+++ b/games-kids/lletters/files/lletters-0.1.95-clang16.patch
@@ -0,0 +1,56 @@
+https://bugs.gentoo.org/874693
+--- a/libqdwav/wav_lib.h
++++ b/libqdwav/wav_lib.h
+@@ -44,2 +44,3 @@
+ int init_wav (char file_name[], wav_sig *info);
++int init_wav_read (char file_name[], wav_sig *info);
+ void get_wav_nextblock (int handle, char *buffer);
+--- a/libqdwav/wav_read.c
++++ b/libqdwav/wav_read.c
+@@ -6,2 +6,3 @@
+ #include <sys/stat.h>
++#include <unistd.h>
+ #include "wav_lib.h"
+--- a/libqdwav/wav_write.c
++++ b/libqdwav/wav_write.c
+@@ -5,2 +5,3 @@
+ #include <sys/soundcard.h>
++#include <unistd.h>
+ #include "wav_lib.h"
+--- a/list.c
++++ b/list.c
+@@ -1,2 +1,3 @@
+ #include <string.h> /* for strs */
++#include <dirent.h>
+ #include "lletters.h"
+@@ -4,6 +5,5 @@
+ /* prototype std lib functions */
+-extern int alphasort ();
+
+ /* local prototypes */
+-int file_select (struct direct *entry);
++int file_select (const struct dirent *entry);
+
+@@ -13,3 +13,3 @@
+ int count, i;
+- struct direct **files;
++ struct dirent **files;
+
+@@ -46,3 +46,3 @@
+ int
+-file_select (struct direct *entry)
++file_select (const struct dirent *entry)
+ { /* ignore . and .. entries */
+--- a/timer.c
++++ b/timer.c
+@@ -1,2 +1,3 @@
+ #include <stdio.h>
++#include <sys/ioctl.h>
+ #include "wav_lib.h"
+--- a/wav_play.c
++++ b/wav_play.c
+@@ -3,2 +3,4 @@
+ #include <stdlib.h>
++#include <sys/ioctl.h>
++#include <unistd.h>
+ #ifdef GSM
diff --git a/games-kids/lletters/lletters-0.1.95-r4.ebuild b/games-kids/lletters/lletters-0.1.95-r5.ebuild
index 52ddc4d05833..b5d6666eb794 100644
--- a/games-kids/lletters/lletters-0.1.95-r4.ebuild
+++ b/games-kids/lletters/lletters-0.1.95-r5.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop
-PATCH_LEVEL=3
-
DESCRIPTION="Game that helps young kids learn their letters and numbers"
-HOMEPAGE="http://lln.sourceforge.net"
-SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}+gtk2.orig.tar.gz
- mirror://debian/pool/main/l/${PN}/${PN}_${PV}+gtk2-${PATCH_LEVEL}.diff.gz
+HOMEPAGE="https://lln.sourceforge.net/"
+SRC_URI="
+ mirror://gentoo/${PN}_${PV}+gtk2.orig.tar.gz
+ mirror://gentoo/${PN}_${PV}+gtk2-3.diff.gz
mirror://sourceforge/lln/${PN}-media-0.1.9a.tar.gz"
LICENSE="GPL-2"
@@ -20,21 +19,22 @@ IUSE="nls"
RDEPEND="
x11-libs/gtk+:2
+ dev-libs/glib:2
nls? ( virtual/libintl )
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
+ nls? ( sys-devel/gettext )"
PATCHES=(
- "${WORKDIR}/${PN}_${PV}+gtk2-${PATCH_LEVEL}.diff"
+ "${WORKDIR}/${PN}_${PV}+gtk2-3.diff"
"${FILESDIR}/${P}-build-2.patch"
"${FILESDIR}/${P}-underlink.patch"
"${FILESDIR}/${P}-make-382.patch"
"${FILESDIR}/${P}-fno-common.patch"
"${FILESDIR}/${P}-nolang.patch"
+ "${FILESDIR}/${P}-clang16.patch"
)
src_prepare() {
@@ -49,7 +49,9 @@ src_configure() {
src_install() {
default
+
newdoc debian/changelog ChangeLog.debian
+
doicon debian/${PN}.xpm
- make_desktop_entry ${PN} "Linux Letters and Numbers" ${PN}
+ make_desktop_entry ${PN} "Linux Letters and Numbers"
}