summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dialup/rp-pppoe/Manifest1
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-4.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-dialup/rp-pppoe/Manifest b/net-dialup/rp-pppoe/Manifest
index ba927df37a83..5b877da0c975 100644
--- a/net-dialup/rp-pppoe/Manifest
+++ b/net-dialup/rp-pppoe/Manifest
@@ -1,2 +1,3 @@
DIST rp-pppoe-3.14-patches-01.tar.xz 4708 BLAKE2B d0c294490f5c4c8f3f81fccb8234d5eec2257350a41206bf05882aa7e2aa0e2cb0944a962d77e23451f604376168298d5ef99c70b134989c35261bae6046b882 SHA512 0ae0f91e8b9cfcd7d1a1af6cb55f7972e9bc029cd4b10469d5be696ae750d6aabb5f59426e9bf6f700d5a56decd3ddf85a097bb98ae1d06f0b167967b5b8b8ea
DIST rp-pppoe-3.15.tar.gz 224966 BLAKE2B 85eda606677b71e35ed3b9389db0d01ac1f16c7b40cc31b3adf31946b18454b77867a5e8822386e9fb08455399733242c4c074c2fee6f1c4d62fe23b44e82707 SHA512 a156c084e57361ab6a464c3205ffb85cf86d02f71f17f92c9567f1ab0ed300f10030832fd232084699dc842ac4891efc8c54c8165587bfc7b4c92724318a60d9
+DIST rp-pppoe-4.0.tar.gz 139539 BLAKE2B ba9f11e547dafdacf6fc4d525488a4ac0279b06d545e0c116e568c92a45eb8ab558ca9112f1debecacde5401cb5974eacdf972b1b4cd813711589b8181e918de SHA512 faebe543988b1ffacd4d9bf55a3ec21f3a541f9232ba6c7b6fa0e8103d6c2b7b1c358e7f7bc8f99bebb24b2f7bdcc2f46ba1ef4c23e6dd34062f8f28114e7aea
diff --git a/net-dialup/rp-pppoe/rp-pppoe-4.0.ebuild b/net-dialup/rp-pppoe/rp-pppoe-4.0.ebuild
new file mode 100644
index 000000000000..49505ea74cfc
--- /dev/null
+++ b/net-dialup/rp-pppoe/rp-pppoe-4.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
+HOMEPAGE="https://dianne.skoll.ca/projects/rp-pppoe/ https://salsa.debian.org/dskoll/rp-pppoe"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=https://github.com/dfskoll/rp-pppoe.git
+else
+ SRC_URI="https://dianne.skoll.ca/projects/rp-pppoe/download/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="tk"
+
+S="${S}/src"
+
+RDEPEND="
+ net-dialup/ppp:=
+ sys-apps/iproute2
+ tk? ( dev-lang/tk:= )
+"
+DEPEND=">=sys-kernel/linux-headers-2.6.25
+ elibc_musl? ( net-libs/ppp-defs )
+ ${RDEPEND}"
+
+DOC_CONTENTS="Use pppoe-setup to configure your dialup connection"
+
+pkg_setup() {
+ # This is needed in multiple phases
+ PPPD_VER="$(best_version net-dialup/ppp)"
+ PPPD_VER="${PPPD_VER#*/*-}" #reduce it to ${PV}-${PR}
+ PPPD_VER="${PPPD_VER%%-*}" #reduce it to ${PV}
+
+ PPPD_PLUGIN_DIR="/usr/$(get_libdir)/pppd/${PPPD_VER}"
+}
+
+src_configure() {
+ addpredict /dev/ppp
+
+ econf --enable-plugin=/usr/include/pppd
+}
+
+src_compile() {
+ emake PLUGIN_PATH=rp-pppoe.so PLUGIN_DIR="${PPPD_PLUGIN_DIR}"
+
+ if use tk ; then
+ emake -C "${S}/../gui"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" PLUGIN_DIR="${PPPD_PLUGIN_DIR}" install
+
+ # We don't need this README file here.
+ rm "${ED}${PPPD_PLUGIN_DIR}/README" || die "Error removing ${PPPD_PLUGIN_DIR}/README from installation"
+
+ if use tk ; then
+ emake -C "${S}/../gui" \
+ DESTDIR="${D}" \
+ datadir=/usr/share/doc/${PF}/ \
+ install
+ dosym doc/${PF}/tkpppoe /usr/share/tkpppoe
+ fi
+
+ newinitd "${FILESDIR}"/pppoe-server.initd pppoe-server
+ newconfd "${FILESDIR}"/pppoe-server.confd pppoe-server
+
+ readme.gentoo_create_doc
+}