summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/embark/Manifest1
-rw-r--r--app-emacs/embark/embark-0.21.ebuild50
-rw-r--r--app-emacs/embark/files/50embark-gentoo.el2
-rw-r--r--app-emacs/embark/metadata.xml29
4 files changed, 82 insertions, 0 deletions
diff --git a/app-emacs/embark/Manifest b/app-emacs/embark/Manifest
new file mode 100644
index 000000000000..e559a244a6de
--- /dev/null
+++ b/app-emacs/embark/Manifest
@@ -0,0 +1 @@
+DIST embark-0.21.tar.gz 102588 BLAKE2B 5a578fe25018591e4dbbe4b683ce1e8669003fdedef3c6eecdf039fdcdc7b2d5accbd95faebe369b5dac90be8beb3be7c0507190f2cac4556a25a58709aef7c9 SHA512 ab450ab17d17fa4673615d6daef9495d4e567ab612f4a732f7536427b71dffecbb0456accc7adb28cedb3f1a73709fa2e51cb01f20902dc7748755ee1ea2442c
diff --git a/app-emacs/embark/embark-0.21.ebuild b/app-emacs/embark/embark-0.21.ebuild
new file mode 100644
index 000000000000..38aa5db83044
--- /dev/null
+++ b/app-emacs/embark/embark-0.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp optfeature
+
+DESCRIPTION="Conveniently act on minibuffer completions inside GNU Emacs"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/${PN}.git"
+else
+ SRC_URI="https://github.com/oantolin/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-consult.el"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.texi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "Avy integration for Embark" app-emacs/avy-embark-collect
+ optfeature "Consult integration for Embark" app-emacs/embark-consult
+}
diff --git a/app-emacs/embark/files/50embark-gentoo.el b/app-emacs/embark/files/50embark-gentoo.el
new file mode 100644
index 000000000000..933ac84875b9
--- /dev/null
+++ b/app-emacs/embark/files/50embark-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/embark-autoloads.el" nil t)
diff --git a/app-emacs/embark/metadata.xml b/app-emacs/embark/metadata.xml
new file mode 100644
index 000000000000..84bb06449c69
--- /dev/null
+++ b/app-emacs/embark/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Embark makes it easy to choose a command to run based on what is near
+ point, both during a minibuffer completion session (in a way familiar to
+ Helm or Counsel users) and in normal buffers. Bind the command embark-act
+ to a key and it acts like prefix-key for a keymap of actions (commands)
+ relevant to the target around point. With point on an URL in a buffer you
+ can open the URL in a browser or eww or download the file it points to. If
+ while switching buffers you spot an old one, you can kill it right there
+ and continue to select another. Embark comes preconfigured with over a
+ hundred actions for common types of targets such as files, buffers,
+ identifiers, s-expressions, sentences; and it is easy to add more actions
+ and more target types. Embark can also collect all the candidates in a
+ minibuffer to an occur-like buffer or export them to a buffer in a
+ major-mode specific to the type of candidates, such as dired for a set of
+ files, ibuffer for a set of buffers, or customize for a set of variables.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/oantolin/embark/issues/</bugs-to>
+ <remote-id type="github">oantolin/embark</remote-id>
+ </upstream>
+</pkgmetadata>