summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild41
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.32.ebuild28
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 7d18f8ebd857..ec6703058afd 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,3 +1 @@
-DIST jsonpatch-1.32.tar.gz 27988 BLAKE2B b60dc7607f644f1ffd095486c237e3bb537b465132725e98fc8799a42a92dcbb43e1e41d281fbc2ce2c4efec327ad681d7740129be55d94c51321e620d084d95 SHA512 4e2978555dd506e09553014d426c4e3a6c6d5c865428f11450952704007c8a0b2060b945cf1fa33a128151427e1c66919891466e095e96fff4316304f0b3ad1d
-DIST python-json-patch-1.32.gh.tar.gz 27988 BLAKE2B b60dc7607f644f1ffd095486c237e3bb537b465132725e98fc8799a42a92dcbb43e1e41d281fbc2ce2c4efec327ad681d7740129be55d94c51321e620d084d95 SHA512 4e2978555dd506e09553014d426c4e3a6c6d5c865428f11450952704007c8a0b2060b945cf1fa33a128151427e1c66919891466e095e96fff4316304f0b3ad1d
DIST python-json-patch-1.33.gh.tar.gz 28475 BLAKE2B 7d95ab23e09141cbe26618c91b12558d5fbfecda3e5b148d834753a364155d30859a9bdc3d321bdfcc5269f7e0170671524ae78f5fe65a8c97041bab3fb522b9 SHA512 0685f63949bee135b19d0962bdaab32ba97e02772b6650d885be57c09a2e89546222ebba1a4cf146b2f91027790b0a3ff2ea072d66dcebf9153aa601638bbfa2
diff --git a/dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild b/dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild
deleted file mode 100644
index db865c090f6c..000000000000
--- a/dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=python-json-patch-${PV}
-DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
-HOMEPAGE="
- https://github.com/stefankoegl/python-json-patch/
- https://pypi.org/project/jsonpatch/
-"
-SRC_URI="
- https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-python_test() {
- "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
- "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
-}
diff --git a/dev-python/jsonpatch/jsonpatch-1.32.ebuild b/dev-python/jsonpatch/jsonpatch-1.32.ebuild
deleted file mode 100644
index a1091af90b37..000000000000
--- a/dev-python/jsonpatch/jsonpatch-1.32.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
-HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
-SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/python-json-patch-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( ${RDEPEND} )
-"
-
-python_test() {
- "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
- "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
-}