summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.0.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index d2b989e626fb..9609e008c67b 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-0.6.0.4.tar.gz 2010373 BLAKE2B 96d31fde6d087bea81051bfcc208d52466b9c45785c2167c61721440fe930906958ee840bb98258c7c1b98c067302049afd63bbf5cfd422a69c1994675c29c70 SHA512 f9a30ad578b80679c0313be84150adff83a90b35c758487fc9f5240d527cf0a905b6257a0dfdf2a2c8c7322688108a6673c56238480344adce123d67416eb197
+DIST Nuitka-0.6.0.6.tar.gz 2011509 BLAKE2B 1a5d37acd50bbb7d1a380306aa18d68ab6559fe3d90b988032cd36458e5ec663c2ba1597f50da89c6b2360f35cd576a2219860b0d74bb3d835db9525d10f22bf SHA512 d893e49a2f91d310b4a86ddd1566990b66ae202bde642af8b7e45554ed6b2abf4b6b694bb03d020b15d9b748c0dd31ac1a79c77fcc9d15468ce37faf475e8beb
diff --git a/dev-python/nuitka/nuitka-0.6.0.6.ebuild b/dev-python/nuitka/nuitka-0.6.0.6.ebuild
new file mode 100644
index 000000000000..0d55ac76041d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6)
+inherit distutils-r1
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="http://www.nuitka.net"
+SRC_URI="http://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ elog "nuitka needs app-admin/chrpath for building"
+ elog "stand-alone executables"
+}