summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild b/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild
index d1128c1f4e5f..0237bc3c236d 100644
--- a/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild
+++ b/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit gnome.org meson python-any-r1
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
DESCRIPTION="Graphical front-ends to various networking command-line"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-nettool"
@@ -39,3 +39,13 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PV}-meson-drop-unused-positional-arguments.patch
)
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}