summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.12.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 83f629ed3b1b..d642b668dd94 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1 +1,2 @@
DIST gspell-1.12.1.tar.xz 442912 BLAKE2B 727db08f0523a9c222ac763e2ae995112862fac772c9208fd42bed535624450efbfe6c8c63d5dc3521f148cd3f6ea591761a8729d1f8f4337ce00e6dbdcff80e SHA512 1498399059b29bd8fe03396a45eb7ea1f00ece7761a63a29ba3e9559f8e3e9e4607022534280bc2ba239fa8cf118f67028b0368b706855fb513172388d951e1c
+DIST gspell-1.12.2.tar.xz 442824 BLAKE2B 6a574339dfa4930e5506d63d5f0cf27d8433c2914ce1204edc8366992ebf05bf78d4777029fa17f05be73291510897862c63479e59e72522a4c4943647f66539 SHA512 c13df805f6128cfd19c41e4936fbb49516f80e09d27e79380d5638cbd1a8a3bfc6aae5ef8a4faa748495fe529bde92805bbd5530610b113c58daa36f273a5af8
diff --git a/app-text/gspell/gspell-1.12.2.ebuild b/app-text/gspell/gspell-1.12.2.ebuild
new file mode 100644
index 000000000000..16d18c659738
--- /dev/null
+++ b/app-text/gspell/gspell-1.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.2:2
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ app-text/enchant:2[hunspell]
+ || (
+ app-dicts/myspell-en[l10n_en(+)]
+ app-dicts/myspell-en[l10n_en-US(+)]
+ )
+ )
+"
+# Tests require a en_US dictionary and fail with deprecated enchant aspell backend:
+# So enchant[hunspell] + myspell-en ensure they pass (hunspell is ordered before aspell),
+# however a different backend like hspell or nuspell + their en_US dict might be fine too,
+# but we don't support them at this time (2020-04-12) in enchant:2
+
+src_prepare() {
+ use vala && vala_setup
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx dbus-run-session emake check
+}