summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/farstream/farstream-0.2.8-r2.ebuild4
-rw-r--r--net-libs/farstream/files/farstream-0.2.8-make43.patch60
2 files changed, 64 insertions, 0 deletions
diff --git a/net-libs/farstream/farstream-0.2.8-r2.ebuild b/net-libs/farstream/farstream-0.2.8-r2.ebuild
index c5a2f6eb67f3..94ad2225e928 100644
--- a/net-libs/farstream/farstream-0.2.8-r2.ebuild
+++ b/net-libs/farstream/farstream-0.2.8-r2.ebuild
@@ -44,6 +44,10 @@ DEPEND="${COMMONDEPEND}
media-libs/gst-plugins-good:1.0 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.8-make43.patch # remove when bumping and switching to Meson
+)
+
pkg_setup() {
python-any-r1_pkg_setup
}
diff --git a/net-libs/farstream/files/farstream-0.2.8-make43.patch b/net-libs/farstream/files/farstream-0.2.8-make43.patch
new file mode 100644
index 000000000000..c1e1c0d42791
--- /dev/null
+++ b/net-libs/farstream/files/farstream-0.2.8-make43.patch
@@ -0,0 +1,60 @@
+--- a/farstream/Makefile.in
++++ b/farstream/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -549,7 +551,7 @@
+ glib_enum_define = FS
+ glib_gen_prefix = _fs
+ glib_gen_basename = fs
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ @HAVE_INTROSPECTION_TRUE@introspection_sources = \
+ @HAVE_INTROSPECTION_TRUE@ $(libfarstream_@FS_APIVERSION@_la_SOURCES) \
+ @HAVE_INTROSPECTION_TRUE@ $(nodist_libfarstreaminclude_HEADERS) \
+--- a/gst/fsrtpconference/Makefile.in
++++ b/gst/fsrtpconference/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -569,7 +571,7 @@
+ glib_enum_define = FS_RTP
+ glib_gen_prefix = _fs_rtp
+ glib_gen_basename = fs-rtp
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: all-am
+
+ .SUFFIXES:
+--- a/transmitters/rawudp/Makefile.in
++++ b/transmitters/rawudp/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -496,7 +498,7 @@
+ glib_enum_define = FS_RAWUDP
+ glib_gen_prefix = _fs_rawudp
+ glib_gen_basename = fs-rawudp
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: all-am
+
+ .SUFFIXES: