summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-3.45.0.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index 2713b7b8577a..9ab1ec4d18f7 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,4 +1,3 @@
-DIST lean-3.45.0.tar.gz 1913638 BLAKE2B f36548be556407cbf7b30a7988bb2454542543cafcd2d0f2af90f75f886d4b711c6955503f7241844ffff69400ec354a194cc345feca8f0dbcb06a673cc2d3d4 SHA512 c97c1dc6004823c73d8e40b5587ebbee7bd7a90b65ecdd3a976510d0d335b6df9a26916eedd5524f7137a32254a59dd5a6f15ce67f77d500926c9bc781aa5526
DIST lean-3.46.0.tar.gz 1913857 BLAKE2B de0a48ab3cff934d6a9583833a94a409a6351bd8433dbf47dbb510620a6c27aae26891472b4f1443e0f833b1c13de8653f0ea4edf61d14d43cfdb1aa25a555bf SHA512 d4487154cf6364b49ce19d1946a0bf0af6faeb1276ef08754a3dbed9bf071c2873eebdb1d6bcbe39ab2aaf5e93a97007ce954fd7c1ca4062fb2e6214e75e3b2b
DIST lean-3.47.0.tar.gz 1917990 BLAKE2B 1249654b3a71d1a3b601c79915232d5f53335cd4a5b3c41f97dd5cb39e86bc5ea3c4208b5ebca9fae43c01b7da64579cdf6bcec12b8861ca69339277efe7431d SHA512 11879e4bc324e036b917af0761d918eb393aa3226a36b305dbcd233988504178082290dab2d2e25bc3b7732cb5246a397e29fbd4c956efa9ea454cb46568d942
DIST lean-3.48.0.tar.gz 1918012 BLAKE2B 4616af2e4d66c56866f321797d6bb05049925f62c2c62c72a3a5552d39cc83c48c1dc2e59b9d81a7341346ed6f3173ef6e69902b8e8a5a24c4af86dace76360b SHA512 9e017484f88fac40e35604643c972d5f316df70c18b00f90b107d994f5e58eeb0637033354c1e0159a9dfc8c72fe3ea9d3b70569b46fc37b22a94c3d7445cdac
diff --git a/sci-mathematics/lean/lean-3.45.0.ebuild b/sci-mathematics/lean/lean-3.45.0.ebuild
deleted file mode 100644
index 6623228581a0..000000000000
--- a/sci-mathematics/lean/lean-3.45.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MAJOR=$(ver_cut 1)
-CMAKE_IN_SOURCE_BUILD="ON"
-
-inherit flag-o-matic cmake readme.gentoo-r1
-
-DESCRIPTION="The Lean Theorem Prover"
-HOMEPAGE="https://leanprover-community.github.io/"
-
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
-else
- SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-S="${WORKDIR}/lean-${PV}/src"
-
-LICENSE="Apache-2.0"
-SLOT="0/${MAJOR}"
-IUSE="debug +threads"
-
-RDEPEND="dev-libs/gmp:="
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-CMakeLists-fix_flags.patch" )
-
-src_configure() {
- local CMAKE_BUILD_TYPE
- if use debug; then
- CMAKE_BUILD_TYPE="Debug"
- else
- CMAKE_BUILD_TYPE="Release"
- fi
-
- filter-lto
-
- local mycmakeargs=(
- -DALPHA=ON
- -DAUTO_THREAD_FINALIZATION=ON
- -DJSON=ON # bug 833900
- -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
- -DMULTI_THREAD=$(usex threads)
- -DUSE_GITHASH=OFF
- )
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # Disable problematic "style_check" cpplint test,
- # this also removes the python test dependency
- --exclude-regex style_check
- )
- cmake_src_test
-}
-
-src_install() {
- cmake_src_install
-
- local DISABLE_AUTOFORMATTING="yes"
- local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
- - Do not install mathlib globally and use local versions
- - Use leanproject from sci-mathematics/mathlib-tools
- $ leanproject global-install
- - Use leanpkg and compile mathlib (which will take some time)
- $ leanpkg install https://github.com/leanprover-community/mathlib"
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}