summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libfm/libfm-1.2.3-r1.ebuild8
-rw-r--r--x11-libs/libfm/libfm-1.2.4.ebuild8
-rw-r--r--x11-libs/libfm/libfm-1.2.5.ebuild6
-rw-r--r--x11-libs/libfm/libfm-9999.ebuild8
4 files changed, 15 insertions, 15 deletions
diff --git a/x11-libs/libfm/libfm-1.2.3-r1.ebuild b/x11-libs/libfm/libfm-1.2.3-r1.ebuild
index aa6f3273385c..c9bde1ffe20f 100644
--- a/x11-libs/libfm/libfm-1.2.3-r1.ebuild
+++ b/x11-libs/libfm/libfm-1.2.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools fdo-mime multilib vala
+inherit autotools multilib vala xdg-utils
MY_PV=${PV/_/}
MY_P="${PN}-${MY_PV}"
@@ -116,9 +116,9 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
diff --git a/x11-libs/libfm/libfm-1.2.4.ebuild b/x11-libs/libfm/libfm-1.2.4.ebuild
index 6b60fec10a32..12d09617ea74 100644
--- a/x11-libs/libfm/libfm-1.2.4.ebuild
+++ b/x11-libs/libfm/libfm-1.2.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools fdo-mime multilib vala
+inherit autotools multilib vala xdg-utils
MY_PV=${PV/_/}
MY_P="${PN}-${MY_PV}"
@@ -121,9 +121,9 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
diff --git a/x11-libs/libfm/libfm-1.2.5.ebuild b/x11-libs/libfm/libfm-1.2.5.ebuild
index ad671cdf555e..1a0ea5310742 100644
--- a/x11-libs/libfm/libfm-1.2.5.ebuild
+++ b/x11-libs/libfm/libfm-1.2.5.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit autotools fdo-mime multilib vala
+inherit autotools multilib vala xdg-utils
MY_PV=${PV/_/}
MY_P="${PN}-${MY_PV}"
@@ -121,9 +121,9 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
diff --git a/x11-libs/libfm/libfm-9999.ebuild b/x11-libs/libfm/libfm-9999.ebuild
index 447a8fc27f50..75b2ae42c535 100644
--- a/x11-libs/libfm/libfm-9999.ebuild
+++ b/x11-libs/libfm/libfm-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
EGIT_REPO_URI="https://github.com/lxde/${PN}"
-inherit autotools git-r3 fdo-mime vala
+inherit autotools git-r3 vala xdg-utils
DESCRIPTION="A library for file management"
HOMEPAGE="http://pcmanfm.sourceforge.net/"
@@ -116,9 +116,9 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_mime_database_update
+ xdg_mimeinfo_database_update
}