summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pylama/Manifest2
-rw-r--r--dev-python/pylama/pylama-7.7.1-r1.ebuild49
-rw-r--r--dev-python/pylama/pylama-8.0.6.ebuild40
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index b1300a657fd4..79d41547fa4b 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -1,4 +1,2 @@
-DIST pylama-7.7.1.tar.gz 34740 BLAKE2B a4bd5aed40c2c4e7bdb9f9968030f0954f0309cff80567b2252ee9576fdb4598714286bda63c22676789d4919662430ef2729089faa70b5cb590784eb47ef1f0 SHA512 298fabffcdf38e3e868e3965de87a0e761bc9dfcfe33320b53057c4e05598bcc22045481ec16ccb8df27f49ea41d6fef82b69fe7327905f93ce74d9350682cf0
-DIST pylama-8.0.6.tar.gz 34223 BLAKE2B 690a0a1197f6512e9511083aa079843f2ca99c9bdb5d74756531db79f7d39e8e0f60a0955b24bc7739edce0376eb79821a796978fb2365789a97628f03f240f8 SHA512 5bc75e5b2a0b141dbe2ca993d13833914980c735b84f3df766bf750909af1eeaba0d554845d8c09f0d8186ff48c8330d9ffa5b565a577ef6506f32672a2c9209
DIST pylama-8.3.6.tar.gz 36190 BLAKE2B f0c9944d3aa205c9f52fdfab6b47ad5ad08f1865db22eef20add0652fcb4355f878026aad9f1babbfcb4f98c13bc5cbaa069d9d7b5c7a775d994a8952f8a8cc5 SHA512 c279f3005e354be448f42addcfeae6025e1dd4acf84e5de0c3ae707ceac4f98e43a07f43be347b26bfb8db4167945db1db547ed7bd9eb73ca78bbc92d26fdfff
DIST pylama-8.3.7.tar.gz 36264 BLAKE2B 8092320c039b5cd45a379a2718443cf03f5cef931767ae765c90096e3b23d5b7242034009eecb40413f05e2de2fd72a4285a91ebbc1fb474d232cffc9c992b94 SHA512 acfab9584e7bd8b146350e6af83975e91391e39c00a0fea23d4e55f46dd684b519088ed68c90e335e334e8526aecab2ad2286a0c082d26a4b867eadcbd8866c8
diff --git a/dev-python/pylama/pylama-7.7.1-r1.ebuild b/dev-python/pylama/pylama-7.7.1-r1.ebuild
deleted file mode 100644
index 0297b0421751..000000000000
--- a/dev-python/pylama/pylama-7.7.1-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Code audit tool for python"
-HOMEPAGE="https://github.com/klen/pylama"
-SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# pypi tarball excludes unit tests
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/mccabe-0.5.2[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- dev-python/pydocstyle[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mypy[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e "s|exclude=\['plugins'\]|exclude=['plugins', 'tests']|" -i setup.py || die
- sed -e 's|^\(def\) \(test_ignore_select\)|\1 _\2|' -i tests/test_config.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Disable eradicate until it is fixed:
- # https://github.com/klen/pylama/issues/190
- tests/test_linters.py::test_eradicate
- )
- epytest tests
-}
diff --git a/dev-python/pylama/pylama-8.0.6.ebuild b/dev-python/pylama/pylama-8.0.6.ebuild
deleted file mode 100644
index c24f6a0bf330..000000000000
--- a/dev-python/pylama/pylama-8.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Code audit tool for python"
-HOMEPAGE="https://github.com/klen/pylama"
-SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/mccabe-0.6.1[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/eradicate[${PYTHON_USEDEP}]
- dev-python/mypy[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/radon[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # not packaged
- tests/test_linters.py::test_quotes
- tests/test_linters.py::test_vulture
-)