summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/vigra/Manifest1
-rw-r--r--media-libs/vigra/vigra-1.11.0.ebuild139
-rw-r--r--media-libs/vigra/vigra-1.11.1-r1.ebuild149
3 files changed, 0 insertions, 289 deletions
diff --git a/media-libs/vigra/Manifest b/media-libs/vigra/Manifest
index 6ba1371af9f8..cc03ca4ec086 100644
--- a/media-libs/vigra/Manifest
+++ b/media-libs/vigra/Manifest
@@ -1,2 +1 @@
-DIST vigra-1.11.0-src.tar.gz 51854568 BLAKE2B 759390546989d52ffa5447b5434bd2d09b7ceba020ff72b953e9a671514ae2969be7a9f2918b21ab80d2952892219444315ad1df46e635e90a47edde957b6f11 SHA512 3cd8fcfc8ba9a1209a37e49c7b5cb0080bc665987805deec0b92cabf8c571c2f09ba47e2850c12204d04b3c830322fc8e47efa19fc537cf78708c22e1d302d6a
DIST vigra-1.11.1-src.tar.gz 55119047 BLAKE2B c67dc61515075843faacb4ee054f3e28b4edd033dc6cb89d3c591827309eafa697b839ca85ff7c68d6aff9d7e08b1d3db73d50e6c3b065a5210b64a90e242444 SHA512 9c1638d626d658fa4b13069e5850b628d91db02bb18b8a9f0a4642fee501ede8a6f4f267d79ca5cd5baf3991e704163345cd18ab7919ff2a93db6bd496096de3
diff --git a/media-libs/vigra/vigra-1.11.0.ebuild b/media-libs/vigra/vigra-1.11.0.ebuild
deleted file mode 100644
index 566354ca414b..000000000000
--- a/media-libs/vigra/vigra-1.11.0.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-MY_P=${P}-src
-MY_V=${PV//\./-}
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads,xml"
-inherit cmake-utils python-r1
-
-DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
-HOMEPAGE="https://ukoethe.github.io/vigra/"
-SRC_URI="https://github.com/ukoethe/vigra/releases/download/Version-${MY_V}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +fftw +hdf5 +jpeg mpi openexr +png +python test +tiff valgrind"
-
-# runtime dependency on python:2.7 is required by the vigra-config script
-RDEPEND="
- dev-lang/python:2.7
- >=dev-libs/boost-1.52.0-r6:=[python?,${PYTHON_USEDEP}]
- fftw? ( sci-libs/fftw:3.0 )
- hdf5? ( >=sci-libs/hdf5-1.8.0:=[mpi?] )
- jpeg? ( virtual/jpeg:0 )
- openexr? ( media-libs/openexr:= )
- png? ( media-libs/libpng:0= )
- python? ( ${PYTHON_DEPS} dev-python/numpy[${PYTHON_USEDEP}] )
- tiff? ( media-libs/tiff:0= )
- valgrind? ( dev-util/valgrind )"
-
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- python? ( >=dev-python/sphinx-1.1.3-r5[${PYTHON_USEDEP}] )
- )
- test? ( >=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="
- doc? ( hdf5 fftw )
- python? ( hdf5 ${PYTHON_REQUIRED_USE} )
- test? ( hdf5 python fftw )"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-7.patch
-)
-
-pkg_setup() {
- use python && python_setup
-}
-
-src_prepare() {
- einfo "Removing shipped docs and VCS files"
- rm -rf doc || die
- rm .git* .travis.yml || die
-
- cmake-utils_src_prepare
-
- # Don't use python_fix_shebang because we can't put this behind USE="python"
- sed -i -e '/env/s:python:python2:' config/vigra-config.in || die
-}
-
-src_configure() {
- vigra_configure() {
- local libdir="$(get_libdir)"
-
- local mycmakeargs=(
- -DAUTOEXEC_TESTS=OFF
- -DDOCDIR="${BUILD_DIR}/doc"
- -DDOCINSTALL="share/doc/${P}"
- -DLIBDIR_SUFFIX="${libdir/lib}"
- -DUSE_DOC=$(usex doc ON OFF) # unused
- -DUSE_FFTW3=$(usex fftw ON OFF) # unused
- -DUSE_JPEG=$(usex jpeg ON OFF) # unused
- -DUSE_MPI=$(usex mpi ON OFF) # unused
- -DUSE_PNG=$(usex png ON OFF) # unused
- -DUSE_TIFF=$(usex tiff ON OFF) # unused
- -DWITH_HDF5=$(usex hdf5 ON OFF)
- -DWITH_OPENEXR=$(usex openexr ON OFF)
- -DWITH_VALGRIND=$(usex valgrind ON OFF)
- -DWITH_VIGRANUMPY=$(usex python ON OFF)
- -DBUILD_TESTING=$(usex test ON OFF) # unused
- -DUSE_AUTOBUILD_TESTS=$(usex test ON OFF) # unused
- -DUSE_CREATE_CTEST_TARGETS=$(usex test ON OFF) # unused
- )
- cmake-utils_src_configure
- }
-
- if use python; then
- python_foreach_impl vigra_configure
- else
- # required for docdir
- _cmake_check_build_dir init
- vigra_configure
- fi
-}
-
-src_compile() {
- local VIGRA_BUILD_DIR
- vigra_compile() {
- cmake-utils_src_compile
- VIGRA_BUILD_DIR="${BUILD_DIR}"
- }
- if use python; then
- python_foreach_impl vigra_compile
- else
- vigra_compile
- fi
-
- if use doc; then
- einfo "Generating Documentation"
- # use build dir from last compile command
- VARTEXFONTS="${T}/fonts" BUILD_DIR="${VIGRA_BUILD_DIR}" cmake-utils_src_make doc
- fi
-}
-
-src_install() {
- if use python; then
- python_foreach_impl cmake-utils_src_install
- python_optimize
- else
- cmake-utils_src_install
- fi
-}
-
-src_test() {
- # perhaps disable tests (see #390447)
- vigra_test() {
- PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake-utils_src_test
- }
- if use python; then
- python_foreach_impl vigra_test
- else
- vigra_test
- fi
-}
diff --git a/media-libs/vigra/vigra-1.11.1-r1.ebuild b/media-libs/vigra/vigra-1.11.1-r1.ebuild
deleted file mode 100644
index c5e8c814dae8..000000000000
--- a/media-libs/vigra/vigra-1.11.1-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-MY_P="${P}-src"
-MY_V="${PV//\./-}"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads,xml"
-
-inherit cmake-utils python-r1
-
-DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
-HOMEPAGE="https://ukoethe.github.io/vigra/"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ukoethe/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ukoethe/${PN}/releases/download/Version-${MY_V}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc +fftw +hdf5 +jpeg mpi openexr +png +python test +tiff valgrind"
-
-# runtime dependency on python:2.7 is required by the vigra-config script
-RDEPEND="
- dev-lang/python:2.7
- >=dev-libs/boost-1.52.0-r6:=[python?,${PYTHON_USEDEP}]
- fftw? ( sci-libs/fftw:3.0 )
- hdf5? ( >=sci-libs/hdf5-1.8.0:=[mpi?] )
- jpeg? ( virtual/jpeg:0 )
- openexr? ( media-libs/openexr:= )
- png? ( media-libs/libpng:0= )
- python? ( ${PYTHON_DEPS} dev-python/numpy[${PYTHON_USEDEP}] )
- tiff? ( media-libs/tiff:0= )
- valgrind? ( dev-util/valgrind )"
-
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- python? ( >=dev-python/sphinx-1.1.3-r5[${PYTHON_USEDEP}] )
- )
- test? ( >=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="
- doc? ( hdf5 fftw )
- python? ( hdf5 ${PYTHON_REQUIRED_USE} )
- test? ( hdf5 python fftw )"
-
-# Severely broken, also disabled in Fedora, bugs #390447, #653442
-RESTRICT="test"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-incorrect-template-parameter-type.patch"
-)
-
-pkg_setup() {
- use python && python_setup
-}
-
-src_prepare() {
- einfo "Removing shipped docs and VCS files"
- rm -rf doc || die
- rm .git* .travis.yml || die
-
- cmake-utils_src_prepare
-
- # Don't use python_fix_shebang because we can't put this behind USE="python"
- sed -i -e '/env/s:python:python2:' config/vigra-config.in || die
-}
-
-src_configure() {
- vigra_configure() {
- local libdir="$(get_libdir)"
-
- local mycmakeargs=(
- -DAUTOEXEC_TESTS=OFF
- -DDOCDIR="${BUILD_DIR}/doc"
- -DDOCINSTALL="share/doc/${P}"
- -DLIBDIR_SUFFIX="${libdir/lib}"
- -DUSE_DOC=$(usex doc ON OFF) # unused
- -DUSE_FFTW3=$(usex fftw ON OFF) # unused
- -DUSE_JPEG=$(usex jpeg ON OFF) # unused
- -DUSE_MPI=$(usex mpi ON OFF) # unused
- -DUSE_PNG=$(usex png ON OFF) # unused
- -DUSE_TIFF=$(usex tiff ON OFF) # unused
- -DWITH_HDF5=$(usex hdf5 ON OFF)
- -DWITH_OPENEXR=$(usex openexr ON OFF)
- -DWITH_VALGRIND=$(usex valgrind ON OFF)
- -DWITH_VIGRANUMPY=$(usex python ON OFF)
- -DBUILD_TESTING=$(usex test ON OFF) # unused
- -DUSE_AUTOBUILD_TESTS=$(usex test ON OFF) # unused
- -DUSE_CREATE_CTEST_TARGETS=$(usex test ON OFF) # unused
- )
- cmake-utils_src_configure
- }
-
- if use python; then
- python_foreach_impl vigra_configure
- else
- # required for docdir
- _cmake_check_build_dir init
- vigra_configure
- fi
-}
-
-src_compile() {
- local VIGRA_BUILD_DIR
- vigra_compile() {
- cmake-utils_src_compile
- VIGRA_BUILD_DIR="${BUILD_DIR}"
- }
- if use python; then
- python_foreach_impl vigra_compile
- else
- vigra_compile
- fi
-
- if use doc; then
- einfo "Generating Documentation"
- # use build dir from last compile command
- VARTEXFONTS="${T}/fonts" BUILD_DIR="${VIGRA_BUILD_DIR}" cmake-utils_src_make doc
- fi
-}
-
-src_install() {
- if use python; then
- python_foreach_impl cmake-utils_src_install
- python_optimize
- else
- cmake-utils_src_install
- fi
-}
-
-src_test() {
- # perhaps disable tests (see #390447)
- vigra_test() {
- PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake-utils_src_test
- }
- if use python; then
- python_foreach_impl vigra_test
- else
- vigra_test
- fi
-}