summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ensurepip-wheels/Manifest2
-rw-r--r--dev-python/ensurepip-wheels/ensurepip-wheels-63.3.0.22.2.1.ebuild28
-rw-r--r--dev-python/ensurepip-wheels/metadata.xml11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/ensurepip-wheels/Manifest b/dev-python/ensurepip-wheels/Manifest
new file mode 100644
index 000000000000..b2bdf913b1c4
--- /dev/null
+++ b/dev-python/ensurepip-wheels/Manifest
@@ -0,0 +1,2 @@
+DIST pip-22.2.1-py3-none-any.whl 2044666 BLAKE2B 702699d059273182f248acb48f6f6c9ec287e2edb3de2c84c05402b4fc82da23c14f76e2d3ed8cc1c281e3c8d8fd1a467963d3b9ab6fa384c16d5057fce1561d SHA512 dad2ce78544502a3ec4492a57acc5c1cf6f34ee1d3200a46cf19246f7eda701524d745237909b154317c3d6be6d4e61b086be9562d31d54b60268ca573692638
+DIST setuptools-63.3.0-py3-none-any.whl 1228351 BLAKE2B 5a7a8d864b5fc992952a4c7f0230c3ebb6f33c7b4fc965ca8bfa4cf3b57948e8353f59074f7374e3d002866333d3ad5fd072ccd479f8470cbfcd14aa635efc54 SHA512 f2df66493fb9520b50e3e93560b17e5aa6f01e5fde27028a550249beb54f3ea6b2d8f0a2bcc57afaff193e38d5b217544c0623b254ac300652aed444abf06a14
diff --git a/dev-python/ensurepip-wheels/ensurepip-wheels-63.3.0.22.2.1.ebuild b/dev-python/ensurepip-wheels/ensurepip-wheels-63.3.0.22.2.1.ebuild
new file mode 100644
index 000000000000..691136b4b5bb
--- /dev/null
+++ b/dev-python/ensurepip-wheels/ensurepip-wheels-63.3.0.22.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+SETUPTOOLS_WHL=setuptools-$(ver_cut 1-3)-py3-none-any.whl
+PIP_WHL=pip-$(ver_cut 4-)-py3-none-any.whl
+
+DESCRIPTION="Shared wheels for ensurepip Python module"
+HOMEPAGE="
+ https://pypi.org/project/pip/
+ https://pypi.org/project/setuptools/
+"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/p/pip/${PIP_WHL}
+ https://files.pythonhosted.org/packages/py3/s/setuptools/${SETUPTOOLS_WHL}
+"
+S=${DISTDIR}
+
+# combined license of setuptools and pip (with its bundled deps)
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${PIP_WHL}" "${SETUPTOOLS_WHL}"
+}
diff --git a/dev-python/ensurepip-wheels/metadata.xml b/dev-python/ensurepip-wheels/metadata.xml
new file mode 100644
index 000000000000..0c63c4e2b6a7
--- /dev/null
+++ b/dev-python/ensurepip-wheels/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pip</remote-id>
+ <remote-id type="pypi">setuptools</remote-id>
+ </upstream>
+</pkgmetadata>