summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/scsiping/scsiping-0.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..4879d3b7f737
--- /dev/null
+++ b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
+HOMEPAGE="https://www.vanheusden.com/Linux/"
+SRC_URI="https://www.vanheusden.com/Linux/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/strip scsiping/d' "${S}"/Makefile
+ default
+}
+
+src_compile() {
+ emake DEBUG='' CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dosbin scsiping
+}
+
+pkg_postinst() {
+ ewarn "WARNING: using scsiping on a device with mounted partitions may be hazardous to your system!"
+}