summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/kxstitch/Manifest2
-rw-r--r--media-gfx/kxstitch/files/kxstitch-2.0.0-imagemagick-7.patch93
-rw-r--r--media-gfx/kxstitch/kxstitch-2.0.0.ebuild41
-rw-r--r--media-gfx/kxstitch/kxstitch-2.1.0.ebuild41
4 files changed, 0 insertions, 177 deletions
diff --git a/media-gfx/kxstitch/Manifest b/media-gfx/kxstitch/Manifest
index 5f57d7200fa3..9c20eaecff72 100644
--- a/media-gfx/kxstitch/Manifest
+++ b/media-gfx/kxstitch/Manifest
@@ -1,3 +1 @@
-DIST kxstitch-2.0.0.tar.xz 1681648 BLAKE2B 669eda3060244636b4ad8bb6e7e7899eb183d7a0f3b264bc40c3bda7146be2a6e10b165165889b7d0043dc5921ff8153775dfa5436546e3cd7be99a4cc144434 SHA512 0ce9ec517659fd9a3163671cdb32d451487aa812355c9abb38cf143192ed49e3e32afc003a0064e9a63303b5de40d8859f92066d886dc06c6d1fe03c8790122f
-DIST kxstitch-2.1.0.tar.xz 1727616 BLAKE2B 34e362b37ef94ed9657254fc4887eb77b0937c4ebdc2b76b09ae9ebbbe6dc490fdafa4c189a87177c26bc1d24fa0b150436a547c3b82dbf74b269fd87f674928 SHA512 c31b8f4c33a86967b02ad2d6c9be84931e607644c8683c41b3160c86fee8714d77a10f770d94ae3905c81261dfdaf13957783a83d2235594656bf2884f944608
DIST kxstitch-2.1.1.tar.xz 1726364 BLAKE2B 47257408f31ca7db4bddf984150baac6cd850206cedb95c73b0d62ee9f966028afd97bb3653b385104a1c679512c35f41aa25c5b703c715e565d48cfda59da36 SHA512 d5a6b6d06bfb894dd7404cb81350389f1ebf5c8a463eb792358abd67f362d1e1f578d06319461a006625864f1c4a69ebb4ccd0db422870c3eae0516c9132a3b3
diff --git a/media-gfx/kxstitch/files/kxstitch-2.0.0-imagemagick-7.patch b/media-gfx/kxstitch/files/kxstitch-2.0.0-imagemagick-7.patch
deleted file mode 100644
index fe53efba3027..000000000000
--- a/media-gfx/kxstitch/files/kxstitch-2.0.0-imagemagick-7.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 295773f44bfda1227d85edf065a8de14dc889159 Mon Sep 17 00:00:00 2001
-From: Steve Allewell <steve.allewell@gmail.com>
-Date: Wed, 25 Oct 2017 20:57:22 +0100
-Subject: Fix for changes to ImageMagick API for importing images
-
----
- src/FlossScheme.cpp | 4 ++--
- src/ImportImageDlg.cpp | 9 ++++++---
- src/MainWindow.cpp | 10 ++++++----
- 3 files changed, 14 insertions(+), 9 deletions(-)
-
-diff --git a/src/FlossScheme.cpp b/src/FlossScheme.cpp
-index 4c59973..e4cd117 100644
---- a/src/FlossScheme.cpp
-+++ b/src/FlossScheme.cpp
-@@ -38,8 +38,8 @@ Floss *FlossScheme::convert(const QColor &color)
- Magick::Image image = Magick::Image(1, 1, "RGB", MagickLib::CharPixel, c);
- #endif
- image.map(*m_map);
-- const Magick::PixelPacket *pixels = image.getConstPixels(0, 0, 1, 1);
-- const Magick::ColorRGB rgb = Magick::Color(*pixels);
-+
-+ const Magick::ColorRGB rgb = image.pixelColor(0,0);
-
- return find(QColor((int)(255*rgb.red()), (int)(255*rgb.green()), (int)(255*rgb.blue())));
- }
-diff --git a/src/ImportImageDlg.cpp b/src/ImportImageDlg.cpp
-index d12ca34..79e8c38 100644
---- a/src/ImportImageDlg.cpp
-+++ b/src/ImportImageDlg.cpp
-@@ -305,9 +305,12 @@ void ImportImageDlg::renderPixmap()
- QProgressDialog progress(i18n("Rendering preview"), i18n("Cancel"), 0, pixelCount, this);
- progress.setWindowModality(Qt::WindowModal);
-
-+#if MagickLibVersion < 0x700
- bool hasTransparency = m_convertedImage.matte();
-- const Magick::PixelPacket *pixels = m_convertedImage.getConstPixels(0, 0, width, height);
--
-+#else
-+ bool hasTransparency = m_convertedImage.alpha();
-+#endif
-+
- for (int dy = 0 ; dy < height ; dy++) {
- QApplication::processEvents();
- progress.setValue(dy * width);
-@@ -317,7 +320,7 @@ void ImportImageDlg::renderPixmap()
- }
-
- for (int dx = 0 ; dx < width ; dx++) {
-- Magick::ColorRGB rgb = Magick::Color(*pixels++);
-+ Magick::ColorRGB rgb = m_convertedImage.pixelColor(dx, dy);
-
- if (hasTransparency && (rgb.alpha() == 1)) {
- //ignore this pixel as it is transparent
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index 9713293..1d22e63 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -543,7 +543,11 @@ void MainWindow::convertImage(const QString &source)
-
- bool useFractionals = importImageDlg->useFractionals();
-
-+#if MagickLibVersion < 0x700
- bool hasTransparency = convertedImage.matte();
-+#else
-+ bool hasTransparency = convertedImage.alpha();
-+#endif
- bool ignoreColor = importImageDlg->ignoreColor();
- Magick::Color ignoreColorValue = importImageDlg->ignoreColorValue();
-
-@@ -564,8 +568,6 @@ void MainWindow::convertImage(const QString &source)
- QProgressDialog progress(i18n("Converting to stitches"), i18n("Cancel"), 0, pixelCount, this);
- progress.setWindowModality(Qt::WindowModal);
-
-- const Magick::PixelPacket *pixels = convertedImage.getConstPixels(0, 0, imageWidth, imageHeight);
--
- for (int dy = 0 ; dy < imageHeight ; dy++) {
- progress.setValue(dy * imageWidth);
- QApplication::processEvents();
-@@ -577,8 +579,8 @@ void MainWindow::convertImage(const QString &source)
- }
-
- for (int dx = 0 ; dx < imageWidth ; dx++) {
-- Magick::ColorRGB rgb = Magick::Color(*pixels++);
--
-+ Magick::ColorRGB rgb = convertedImage.pixelColor(dx, dy);
-+
- if (hasTransparency && (rgb.alpha() == 1)) {
- // ignore this pixel as it is transparent
- } else {
---
-cgit v0.11.2
-
diff --git a/media-gfx/kxstitch/kxstitch-2.0.0.ebuild b/media-gfx/kxstitch/kxstitch-2.0.0.ebuild
deleted file mode 100644
index 02fe8204fac4..000000000000
--- a/media-gfx/kxstitch/kxstitch-2.0.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_HANDBOOK="forceoptional"
-inherit kde5
-
-DESCRIPTION="Program to create cross stitch patterns"
-HOMEPAGE="https://userbase.kde.org/KXStitch"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep ktextwidgets)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtprintsupport)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- $(add_qt_dep qtxml)
- media-gfx/imagemagick[cxx]
- x11-libs/libX11
- !media-gfx/kxstitch:4
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
-"
-
-PATCHES=( "${FILESDIR}/${P}-imagemagick-7.patch" )
diff --git a/media-gfx/kxstitch/kxstitch-2.1.0.ebuild b/media-gfx/kxstitch/kxstitch-2.1.0.ebuild
deleted file mode 100644
index 3e24a1c98c3e..000000000000
--- a/media-gfx/kxstitch/kxstitch-2.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_HANDBOOK="forceoptional"
-inherit kde5
-
-DESCRIPTION="Program to create cross stitch patterns"
-HOMEPAGE="https://userbase.kde.org/KXStitch"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="~amd64"
-IUSE=""
-
-COMMON_DEPEND="
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep ktextwidgets)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtprintsupport)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- $(add_qt_dep qtxml)
- media-gfx/imagemagick[cxx]
- x11-libs/libX11
-"
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
-"
-RDEPEND="${COMMON_DEPEND}
- !media-gfx/kxstitch:4
-"