summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index a94fe235d597..5409e3d0e844 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -1,2 +1,3 @@
DIST system-monitoring-center-2.21.1.tar.gz 1505833 BLAKE2B a2270f20e745191eb72c299d2d4f9a28d5a06ec538813ed60afa628bc4cc053a5ca3e0a5daacc60008d46de55a03d7403e2dbec1f3d62fa67361661bc0101ace SHA512 acc3ea1623407aec703efdd8461a67bb858446b6dbcecfddbf26e0edea1c39ca0cd64d0f81d662340d540cf4fe855bcbc8eb20b48af7f2caea2e7b39169c8c53
DIST system-monitoring-center-2.21.2.tar.gz 1511509 BLAKE2B 44c573a83cc8eb3288543e5ab69c334d0d47dbc1fe05d64f6197a870f7df9c81cd3c57fb67c4219e04bd889554a057276af388e8374de15d02e83ec7ff487ae2 SHA512 95d7622079aa2fa89b1f7e98c886e2c215a204b6cc2b52d4e2892964350639004514fbbd1244df9c70acc7238308071b459997dacc7fa997aae840c9cc95e817
+DIST system-monitoring-center-2.22.1.tar.gz 1741958 BLAKE2B 152e8d461219449bee1950172d52807fdf752503cc7446053cd76916fc8cf8045bb5a0e73ba75bdfc9c20f06a1ca0924366a31cb05f724e84fa14dcc3bae0ca0 SHA512 3a5e38d5e81a354442ba304e4b30faf5d1848fd7ec876508858a1dcf69bba2abfcea87191a5facab01bc02db79fbea9c992ae9b749812d30346c1024b2f35745
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild
new file mode 100644
index 000000000000..0d57d2200134
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}