summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch39
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild37
2 files changed, 76 insertions, 0 deletions
diff --git a/x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch b/x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch
new file mode 100644
index 000000000000..95b96f627ed3
--- /dev/null
+++ b/x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/919373
+https://gitlab.freedesktop.org/xorg/lib/libxaw3d/-/merge_requests/10
+
+From 7b4af57e8a1471747e17fff184032d8250e598b6 Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Thu, 7 Dec 2023 18:01:47 -0800
+Subject: [PATCH] Multisink.c: Clear -Werror=incompatible-pointer-types error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+MultiSink.c: In function ‘SetValues’:
+MultiSink.c:582:18: error: passing argument 1 of ‘SetTabs’ from
+ incompatible pointer type [-Werror=incompatible-pointer-types]
+ 582 | SetTabs( w, w->text_sink.tab_count, w->text_sink.char_tabs );
+ | ^
+ | |
+ | MultiSinkObject {aka struct _MultiSinkRec *}
+MultiSink.c:99:21: note: expected ‘Widget’ {aka ‘struct _WidgetRec *’}
+ but argument is of type ‘MultiSinkObject’ {aka ‘struct _MultiSinkRec *’}
+ 99 | static void SetTabs(Widget, int, short *);
+ | ^~~~~~
+
+Adopts change originally made to libXaw in XFree86 4
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+--- a/src/MultiSink.c
++++ b/src/MultiSink.c
+@@ -579,7 +579,7 @@ SetValues(Widget current, Widget request, Widget new, ArgList args, Cardinal *nu
+ if ( w->multi_sink.fontset != old_w->multi_sink.fontset ) {
+ ((TextWidget)XtParent(new))->text.redisplay_needed = True;
+ #ifndef NO_TAB_FIX
+- SetTabs( w, w->text_sink.tab_count, w->text_sink.char_tabs );
++ SetTabs((Widget)w, w->text_sink.tab_count, w->text_sink.char_tabs);
+ #endif
+ }
+
+--
+GitLab
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild
new file mode 100644
index 000000000000..180315f6ad32
--- /dev/null
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw3d library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ app-alternatives/yacc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.5-c99.patch
+)
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-internationalization
+ $(use_enable xpm multiplane-bitmaps)
+ --enable-gray-stipples
+ --enable-arrow-scrollbars
+ )
+ xorg-3_src_configure
+}