summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/jinx/Manifest2
-rw-r--r--app-emacs/jinx/files/50jinx-gentoo.el2
-rw-r--r--app-emacs/jinx/files/jinx-0.6-try-load-path.patch32
-rw-r--r--app-emacs/jinx/jinx-0.7.ebuild (renamed from app-emacs/jinx/jinx-0.6.ebuild)5
4 files changed, 3 insertions, 38 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index cc55fa667dc7..84298b78d244 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1 +1 @@
-DIST jinx-0.6.tar.xz 16692 BLAKE2B 49a391b55b809dd6749ce264b4f732b5c902c1ea67a39e681327ddcf8f728271897202ecd282dc5c4999cf336a5b37c89b9863239291fc944cee352920d99189 SHA512 aa253836d04aec04674ca6dbbd1e73719bee78f4d01d4d93eef2cb05f4c3edc6ec4a11c352fb8952780523f187581fae9c33ea0d30416ec30803b7a196d03f60
+DIST jinx-0.7.tar.xz 17816 BLAKE2B d31ae1c35c5808237890c5c6ecaab915af7cc70260ae05de06c049a9bc250c3ff824a18256715fb7ed12e02df60b24aa957192b95fd3a0ab28e5102f5cf63718 SHA512 ed291b1d5eb5b799f629ed3d0d5bfca65e7f11d9349a672f09087a47ebe65a7bc8bef8fda6d344472dc8bc14c97c5d49c79365d45da5c9570e0cf84d51723928
diff --git a/app-emacs/jinx/files/50jinx-gentoo.el b/app-emacs/jinx/files/50jinx-gentoo.el
index 35fde43c0137..dda9db8dd61b 100644
--- a/app-emacs/jinx/files/50jinx-gentoo.el
+++ b/app-emacs/jinx/files/50jinx-gentoo.el
@@ -1,4 +1,4 @@
;;; app-emacs/jinx site configuration -*- lexical-binding: t; -*-
(add-to-list 'load-path "@SITELISP@")
(add-to-list 'load-path "@EMACSMODULES@")
-(load "@SITELISP@/jinx-autoload.el" nil t)
+(load "@SITELISP@/jinx-autoloads.el" nil t)
diff --git a/app-emacs/jinx/files/jinx-0.6-try-load-path.patch b/app-emacs/jinx/files/jinx-0.6-try-load-path.patch
deleted file mode 100644
index 5cb498015791..000000000000
--- a/app-emacs/jinx/files/jinx-0.6-try-load-path.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3c0aa84130e07cf69219adce8a3494e76977fc26 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@gentoo.org>
-Date: Tue, 18 Apr 2023 01:29:55 +0200
-Subject: [PATCH] Try searching the whole load-path for jinx-mod
-
-* jinx.el (jinx--load-module): Try to (locate-library module)
-before trying to look for a sibling file of jinx.el.
----
-https://github.com/minad/jinx/pull/42
-
- jinx.el | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/jinx.el b/jinx.el
-index d0cf56d..e829d50 100644
---- a/jinx.el
-+++ b/jinx.el
-@@ -472,6 +472,11 @@ If VISIBLE is non-nil, only include visible overlays."
- (let ((default-directory
- (file-name-directory (locate-library "jinx.el" t)))
- (module (file-name-with-extension "jinx-mod" module-file-suffix)))
-+
-+ (let ((located-module (locate-library module)))
-+ (when located-module
-+ (setq module located-module)))
-+
- (unless (file-exists-p module)
- (let ((command
- `("cc" "-I." "-O2" "-Wall" "-Wextra" "-fPIC" "-shared"
---
-2.40.0
-
diff --git a/app-emacs/jinx/jinx-0.6.ebuild b/app-emacs/jinx/jinx-0.7.ebuild
index 4cb2cfcb7ae9..3708e4eda694 100644
--- a/app-emacs/jinx/jinx-0.6.ebuild
+++ b/app-emacs/jinx/jinx-0.7.ebuild
@@ -23,12 +23,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+ELISP_REMOVE="${PN}-pkg.el"
SITEFILE="50${PN}-gentoo.el"
-PATCHES=(
- "${FILESDIR}"/jinx-0.6-try-load-path.patch
-)
-
src_compile() {
edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
$($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \