summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/racket-mode/Manifest1
-rw-r--r--app-emacs/racket-mode/racket-mode-1_p20230506.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/app-emacs/racket-mode/Manifest b/app-emacs/racket-mode/Manifest
index 9995554c6eb0..cbe0cd6d8cfc 100644
--- a/app-emacs/racket-mode/Manifest
+++ b/app-emacs/racket-mode/Manifest
@@ -1,2 +1 @@
-DIST racket-mode-1_p20230506.tar.gz 323446 BLAKE2B 087377a6491014c6d29728a4c3a29e75069b729eddfa339d5cd347102f884dc7eb069097b0bf0864779b861e64a132b497ea0eb202238b06fa3741d4a42a5003 SHA512 6b3d37901e3126d8b3597ab83b5c47869873e4fccf536eed4d9ff1ed1695af7ab551bad5807b37438d20950529032b7dc75f9079d95bcf5b088ff097454c48ae
DIST racket-mode-1_p20230905.tar.gz 323536 BLAKE2B 449655a43346d0f000396781302461bc229b7769b68e6f8268e295a0c0fdea2786d7c759fd2e002dfd993b4cab087d1f497c53da29a5a3c7635e8807536b3d8d SHA512 ade32d446816024eefcf84f5e1939cbd8ba561bb58454c543f6d49f118e4a937a069cb7e62bff5f9b1c2479175e5cd8c380bc81f14fadaa139110956cd129cf4
diff --git a/app-emacs/racket-mode/racket-mode-1_p20230506.ebuild b/app-emacs/racket-mode/racket-mode-1_p20230506.ebuild
deleted file mode 100644
index 7690b9a62668..000000000000
--- a/app-emacs/racket-mode/racket-mode-1_p20230506.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-[[ ${PV} == *_p20230506 ]] && COMMIT=c2fe266c18bb6e55a13c7ba795b0a5f7372b6c13
-
-inherit elisp
-
-DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
-HOMEPAGE="https://www.racket-mode.com/
- https://github.com/greghendershott/racket-mode/"
-SRC_URI="https://github.com/greghendershott/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COMMIT}
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="dev-scheme/racket:=[-minimal]"
-BDEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
-
-DOCS=( CONTRIBUTING.org README.org THANKS.org )
-ELISP_TEXINFO="doc/racket-mode.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i "${S}"/racket-util.el || die
-}
-
-src_compile() {
- elisp_src_compile
-
- # Equivalent to compiling from Emacs with "racket-mode-start-faster",
- # because this is installed globally we have to compile it now.
- ebegin "Compiling Racket source files"
- find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
- eend $? "failed to compile Racket source files" || die
-}
-
-src_test() {
- # Set "PLTUSERHOME" to a safe temp directory to prevent writing to ~.
- PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
-}
-
-src_install() {
- elisp_src_install
-
- # Install Racket files to "${SITEETC}".
- insinto "${SITEETC}/${PN}"
- doins -r racket
-}