summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask-api/Manifest1
-rw-r--r--dev-python/flask-api/files/flask-api-2.0-fix-pypy-tests.patch22
-rw-r--r--dev-python/flask-api/flask-api-2.0.ebuild32
3 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/flask-api/Manifest b/dev-python/flask-api/Manifest
index 536afd7f973b..d0febe800a5f 100644
--- a/dev-python/flask-api/Manifest
+++ b/dev-python/flask-api/Manifest
@@ -1,2 +1 @@
-DIST flask-api-2.0.tar.gz 235593 BLAKE2B fadd746d91cc2c797a2e40ee6b11532eb0184a1289a692f8de844501a6656eaa1e87d10811119f267344185b22ed5c12bca43198d64d50ca8055ce95d0f62f19 SHA512 631e69e5a786598e6b5ef7e02c5c4f293eadd84d86fdf0155771d04fb6e87be5686756db90ab265cc097ae3d623c31dcebf5096a62c660d6f7d6fb1c3f3d4e3f
DIST flask-api-3.0.tar.gz 249620 BLAKE2B 63ce0ce6a2d4755caf40c020fc6b88f3b585b0c30f5800df62c8e442f629b8b489917ff0f0d1266d941478336f38aa0560c144620f6c11d60cbd9e31870bf984 SHA512 c86b919f8681a73be166ddc50022faecb376b1b6f99bd0d78b2f2fc8b64f82bf82779dbdcfbcaa1c5e321ea2d286b95f1a1aab32864e6c3923417d7828c7c79a
diff --git a/dev-python/flask-api/files/flask-api-2.0-fix-pypy-tests.patch b/dev-python/flask-api/files/flask-api-2.0-fix-pypy-tests.patch
deleted file mode 100644
index 4d30691b60d3..000000000000
--- a/dev-python/flask-api/files/flask-api-2.0-fix-pypy-tests.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-commit beb6a364de93a429398a9491e16f60a7aa82f51d
-Author: Louis Sautier <sautier.louis@gmail.com>
-Date: Tue Sep 22 00:46:38 2020 +0200
-
- Fix tests with PyPy, remove unused Python2-related code
-
-diff --git a/flask_api/tests/test_parsers.py b/flask_api/tests/test_parsers.py
-index 90a6b83..b7968f6 100644
---- a/flask_api/tests/test_parsers.py
-+++ b/flask_api/tests/test_parsers.py
-@@ -36,9 +36,9 @@ class ParserTests(unittest.TestCase):
- with self.assertRaises(exceptions.ParseError) as context:
- parser.parse(stream, mediatypes.MediaType('application/json'))
- detail = str(context.exception)
-- expected_py2 = 'JSON parse error - Expecting property name: line 1 column 1 (char 1)'
-+ expected_pypy = 'JSON parse error - Key name must be string at char: line 1 column 2 (char 1)'
- expected_py3 = 'JSON parse error - Expecting property name enclosed in double quotes: line 1 column 2 (char 1)'
-- self.assertIn(detail, (expected_py2, expected_py3))
-+ self.assertIn(detail, (expected_pypy, expected_py3))
-
- def test_invalid_multipart(self):
- parser = parsers.MultiPartParser()
diff --git a/dev-python/flask-api/flask-api-2.0.ebuild b/dev-python/flask-api/flask-api-2.0.ebuild
deleted file mode 100644
index 3d030534fe17..000000000000
--- a/dev-python/flask-api/flask-api-2.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Browsable web APIs for Flask"
-HOMEPAGE="https://www.flaskapi.org/"
-# pypi mirror don't have docs folder
-SRC_URI="https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
-"
-
-# https://github.com/flask-api/flask-api/pull/117
-PATCHES=( "${FILESDIR}/${P}-fix-pypy-tests.patch" )
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc docs/about/* docs/api-guide/* docs/index.md
-}