summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/async/Manifest2
-rw-r--r--dev-haskell/async/async-2.2.4.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/async/Manifest b/dev-haskell/async/Manifest
index c12ebc6df2aa..de9de7eaf892 100644
--- a/dev-haskell/async/Manifest
+++ b/dev-haskell/async/Manifest
@@ -1 +1,3 @@
DIST async-2.2.2.tar.gz 12927 BLAKE2B a0fa95525153e1065888072d4c7590a6184fbbedd957d0a7867235414681c9959be385a75007160d50fb3a9e015c83651175c4399f24b7a0d981cfbe0f8bf250 SHA512 6984c74b76dc1db73363ca2e360d2be6f2e7b4de5c7de452c4df7ee996b2256790a8cecb532af6d7d675541315a16f8e4ce566c5f79e4102e4a857f057e2d811
+DIST async-2.2.4.cabal 3095 BLAKE2B cb0491c2fa792c794308485031c8cb876b596f37f06bc53eb824eb09d83f539d315b1e5a49478fef5282609ab755c22442051684dda79e94dc02bca7cb2c5824 SHA512 a19d1ce77902377fe6afc24c10002ef539d21fb402cf245e0816a67086c2a13b0b2e7b984e054a6b846f2acbcbd0fd942819e381e8ff29ba995757cbf8d8aa8f
+DIST async-2.2.4.tar.gz 14148 BLAKE2B c47e47a4bbe98d05bdd6b8ad89888013643f36ea5ede8af306b98749cec3cf9c3e87330339af4152cf7e84f5b9ced39c1eb69079921d4c0b7c993191bc052c2d SHA512 24f37f974dd7573138475d04c0fccb97fcbd8b3de56f7d06199b8f936fd9a29cd0ba0574212a753a81de8958b3292ecee79d0e8d0d2f51eb91874424e6219569
diff --git a/dev-haskell/async/async-2.2.4.ebuild b/dev-haskell/async/async-2.2.4.ebuild
new file mode 100644
index 000000000000..8d3cd7b0109b
--- /dev/null
+++ b/dev-haskell/async/async-2.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -bench
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="1"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bench
+}