summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index ff1db9bfe5d8..e6c4b1a04da5 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.10.2.tar.bz2 3049859 BLAKE2B 92e406a77f3538cfc9f5b23b7eb749df0593a4eb50eee6b7d589f00d3f30ce64a58557167189f0306a9079f7ff3ad09c8f67a822b63360ee45d35854b8e55704 SHA512 77df6d10772e47fc6b3cf4db2396b8c6ad87b6b3afb59b2a256d4c52c9f69db30039ee8c6d7b3fbabd613815cad284ecdf7b267293de7ebee76faaa583d89a11
+DIST xfce4-weather-plugin-0.11.0.tar.bz2 3019896 BLAKE2B 3ab8c2d16efb47f921ad5b6511428545553959fec52973f0735706d42b8b260c10f6a1be6db56e9b6f02bca75eaf41d8543be6ac3afd7bb1e44a75d9b6615ff3 SHA512 f4534d47f825358752ec6252fd0fc49a44ac682e4cdce960d744cd343f5f670473fa4175c59849282352dc75ca9b22b83d7ace68cedfc7dc89bcb21be24ccf86
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.0.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.0.ebuild
new file mode 100644
index 000000000000..3d7d168e68be
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.50
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.12:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}