summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild
index 3028242fe9f6..9635d97c1190 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild
@@ -75,8 +75,12 @@ src_unpack() {
src_prepare() {
cmake-utils_src_prepare
+ # apply the fixes for new glibc / split tirpc
+ eapply "${FILESDIR}/9999/0001-sanitizer_common-Fix-using-libtirpc-on-Linux.patch"
+ eapply "${FILESDIR}/9999/0002-test-Support-using-libtirpc-on-Linux.patch"
+
if use test; then
- # remove tests that are broken by new glibc
+ # remove tests that are (still) broken by new glibc
# https://bugs.llvm.org/show_bug.cgi?id=36065
if use elibc_glibc && has_version '>=sys-libs/glibc-2.25'; then
rm test/lsan/TestCases/Linux/use_tls_dynamic.cc || die
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
index 6d2a4a7a40b7..e50fb3c855ab 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
@@ -74,8 +74,12 @@ src_unpack() {
src_prepare() {
cmake-utils_src_prepare
+ # apply the fixes for new glibc / split tirpc
+ eapply "${FILESDIR}/9999/0001-sanitizer_common-Fix-using-libtirpc-on-Linux.patch"
+ eapply "${FILESDIR}/9999/0002-test-Support-using-libtirpc-on-Linux.patch"
+
if use test; then
- # remove tests that are broken by new glibc
+ # remove tests that are (still) broken by new glibc
# https://bugs.llvm.org/show_bug.cgi?id=36065
if use elibc_glibc && has_version '>=sys-libs/glibc-2.25'; then
rm test/lsan/TestCases/Linux/use_tls_dynamic.cc || die