summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyxattr/pyxattr-9999.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pyxattr/pyxattr-9999.ebuild b/dev-python/pyxattr/pyxattr-9999.ebuild
deleted file mode 100644
index b6f6836aa8cc..000000000000
--- a/dev-python/pyxattr/pyxattr-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1 eutils git-r3
-
-DESCRIPTION="Python interface to xattr"
-HOMEPAGE="https://pyxattr.k1024.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/iustin/${PN}.git"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-
-RDEPEND="sys-apps/attr"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-src_test() {
- # Perform the tests in /var/tmp; that location is more likely
- # to have xattr support than /tmp which is often tmpfs.
- export TESTDIR=/var/tmp
-
- einfo 'Please note that the tests fail if xattrs are not supported'
- einfo 'by the filesystem used for /var/tmp.'
- distutils-r1_src_test
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}