summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-8.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 7a180364f47f..26031d0ca58f 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,2 +1 @@
DIST gentoo-syntax-10.tar.bz2 20945 BLAKE2B 7e081ae2d1498fc0b0616c750881c6f47cbae21d88d876c33d54bae0ff32f5eca44a004e31714fa4af0d351656c72df9e69f33ff0f97e6a2c59d835aacbd44a6 SHA512 790e24ac5427b50f1cd332b895e477bc9715a681cf8c21aaaff722151e6245b45fb33f49465258280eab6a903f3b0c8a8d40b935f44942b6b93f5c0d3c7c420a
-DIST gentoo-syntax-8.tar.bz2 21280 BLAKE2B 81854e79fe206fda53cd4566c9e761fbac321929bfbaa7adb042750df60646a9ff494fb623af1d6540722fd0bb37106fbb8e50a7f0f602989adff3d88a58f41e SHA512 af3719dac995064861ba369786206433d92275d586e407f0d6b92f37cbb9f4b96a73b24193d21f59c6398cf51857f1292e4e2c647f0ee70d141db68c7db80b87
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-8.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-8.ebuild
deleted file mode 100644
index 8505d4bfb08a..000000000000
--- a/app-vim/gentoo-syntax/gentoo-syntax-8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
-HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
-SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
-
-LICENSE="vim"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ignore-glep31"
-
-VIM_PLUGIN_HELPFILES="gentoo-syntax"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- if use ignore-glep31 ; then
- for f in ftplugin/*.vim ; do
- ebegin "Removing UTF-8 rules from ${f} ..."
- sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
- || die "waah! bad sed voodoo. need more goats."
- eend $?
- done
- fi
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use ignore-glep31 1>/dev/null ; then
- ewarn "You have chosen to disable the rules which ensure GLEP 31"
- ewarn "compliance. When editing ebuilds, please make sure you get"
- ewarn "the character set correct."
- fi
- fi
-}