summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-pda/ifuse/Manifest1
-rw-r--r--app-pda/ifuse/ifuse-1.1.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-pda/ifuse/Manifest b/app-pda/ifuse/Manifest
index 81516e084162..9f75cb19468c 100644
--- a/app-pda/ifuse/Manifest
+++ b/app-pda/ifuse/Manifest
@@ -1 +1,2 @@
DIST ifuse-1.1.3.tar.bz2 90803 BLAKE2B fd47f2e73d11e8f7c26f5684f4287ba51a8c65b0d6e0ff058bdd0290810ab9de671a2a61a089713e7560506f607d47692d882c7e49d8d3d154f9cf7940e5e153 SHA512 bacf0b00ebc7681022f6e85daa005ee19c99f3222e5db5c4ea6630c2c46111dd3ccd7efcfdbcfabf06cc18ceb58b054c1adb2d106d9b3b7d60a12f3b79c64a3c
+DIST ifuse-1.1.4.tar.bz2 94137 BLAKE2B 0abe1a2324820380faf5868f59a45c11aab8991ff8529bd6f64a279b046da88a9cd35b352cd89b4a64d36f35c56b46efab5138f3b72ec8886103ffaaeeff50f1 SHA512 671fabb0828fb6dd5ddba80ef418005305f4ee4676ab1078513a83582e84616f47c8973c25e1fdd8897b08a01a135080898a55d3ad8b31e89c0bb72ee865cdff
diff --git a/app-pda/ifuse/ifuse-1.1.4.ebuild b/app-pda/ifuse/ifuse-1.1.4.ebuild
new file mode 100644
index 000000000000..5e92a5c73c47
--- /dev/null
+++ b/app-pda/ifuse/ifuse-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="https://www.libimobiledevice.org/ https://github.com/libimobiledevice/ifuse/"
+SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-pda/libimobiledevice-1.3.0:=
+ >=app-pda/libplist-2.2:=
+ sys-fs/fuse:0
+"
+RDEPEND="
+ ${DEPEND}
+ app-pda/usbmuxd
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Only use this filesystem driver to create backups of your data.
+The music database is hashed, and attempting to add files will cause the
+iPod/iPhone to consider your database unauthorised.
+It will respond by wiping all media files, requiring a restore through iTunes."
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}