summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/safeeyes/Manifest1
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.6.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/Manifest b/x11-misc/safeeyes/Manifest
index 67b3f4e4a423..6b686165b96b 100644
--- a/x11-misc/safeeyes/Manifest
+++ b/x11-misc/safeeyes/Manifest
@@ -1 +1,2 @@
DIST safeeyes-2.1.5.tar.gz 284690 BLAKE2B deedf39bc0a69ee70a692061c96e0ea5ce6aeb09513d7469710d25b8660eaed854b3ee711de4702f839dbfb1f04aee84cb05ebc24d4567fc2b56c04e319f5c63 SHA512 0e4ed1d9f4473b45f6f5d4a74ba4817fca08199072fe937fd3b7ceed1ef543729c618e672198cf4dfeba8ed896b24779ca725f2f2c98bf1c9cdf1a8e9c147dc8
+DIST safeeyes-2.1.6.tar.gz 286359 BLAKE2B a5e4b4d680d455f2ae9494705f1e4508341802f4826b2d11f5407eed4074f0eab45066a3741745dd164b47e26a2dbf2a393945bffef0f747cbebd5f87b3b1961 SHA512 6476284ed1d8cdde77f10b3fe962a5d9d5ead944b0418f797e375cc67affa6807d858279cf4a1189585b7688dbe983fc6b90c917e0e55a2a11ebfdc56b44ca93
diff --git a/x11-misc/safeeyes/safeeyes-2.1.6.ebuild b/x11-misc/safeeyes/safeeyes-2.1.6.ebuild
new file mode 100644
index 000000000000..5aca9341d36c
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}