summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/cacti/cacti-1.0.4-r1.ebuild (renamed from net-analyzer/cacti/cacti-1.0.4.ebuild)9
-rw-r--r--net-analyzer/cacti/cacti-1.0.5-r1.ebuild (renamed from net-analyzer/cacti/cacti-1.0.5.ebuild)9
2 files changed, 10 insertions, 8 deletions
diff --git a/net-analyzer/cacti/cacti-1.0.4.ebuild b/net-analyzer/cacti/cacti-1.0.4-r1.ebuild
index f2641066e9cc..71f1fc113946 100644
--- a/net-analyzer/cacti/cacti-1.0.4.ebuild
+++ b/net-analyzer/cacti/cacti-1.0.4-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+WEBAPP_MANUAL_SLOT="yes"
inherit eutils webapp
# Support for _p* in version.
@@ -11,6 +12,7 @@ DESCRIPTION="Cacti is a complete frontend to rrdtool"
HOMEPAGE="http://www.cacti.net/"
SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+SLOT="${PV}"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="snmp doc"
@@ -38,13 +40,12 @@ src_prepare() {
src_compile() { :; }
src_install() {
- webapp_src_preinst
-
dodoc docs/{CHANGELOG,txt/manual.txt}
- docinto html
- doins -r docs/html/
+ dodoc -r docs/html/
rm -rf docs
+ webapp_src_preinst
+
edos2unix `find -type f -name '*.php'`
dodir ${MY_HTDOCSDIR}
diff --git a/net-analyzer/cacti/cacti-1.0.5.ebuild b/net-analyzer/cacti/cacti-1.0.5-r1.ebuild
index f2641066e9cc..71f1fc113946 100644
--- a/net-analyzer/cacti/cacti-1.0.5.ebuild
+++ b/net-analyzer/cacti/cacti-1.0.5-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+WEBAPP_MANUAL_SLOT="yes"
inherit eutils webapp
# Support for _p* in version.
@@ -11,6 +12,7 @@ DESCRIPTION="Cacti is a complete frontend to rrdtool"
HOMEPAGE="http://www.cacti.net/"
SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+SLOT="${PV}"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="snmp doc"
@@ -38,13 +40,12 @@ src_prepare() {
src_compile() { :; }
src_install() {
- webapp_src_preinst
-
dodoc docs/{CHANGELOG,txt/manual.txt}
- docinto html
- doins -r docs/html/
+ dodoc -r docs/html/
rm -rf docs
+ webapp_src_preinst
+
edos2unix `find -type f -name '*.php'`
dodir ${MY_HTDOCSDIR}