summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.5.18.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 0f6540a68c2a..b03fa22f15a2 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2022.4.8.tar.gz 2257195 BLAKE2B 1d83ef14900789d0af0fc80bafcd6d80ca3162ede818d74382598161014c1a4c4450c0cdf57cdc79f3c5e2970a46004619eeffa9dfdb0d7af128bbe2a023ebf8 SHA512 b2d865682ba44dbd168cd76089105fc1d7ff2d79ba884c9626b3a4009c05f07eccaed2b8801318e89e3e197affc70aad68c1813590eef2a5148ded9c037bf0ce
+DIST yt-dlp-2022.5.18.tar.gz 2277146 BLAKE2B 95237fcb12aef9d849e5cc5603baeb5b8e6f416db2dad04d8ea7408b966dcd0d05ad3e276342fb9cc3551293a569b48d2b806c360e95c9c96ffb17dff4cbeb9a SHA512 d0c11e6dba336124898e73234c5935386163af8a9dbbe3e2c38ec834ff631557a763e5224c30747dcffcf98364b95b7f1b6121c50ef91ed56653e2ce453548b5
diff --git a/net-misc/yt-dlp/yt-dlp-2022.5.18.ebuild b/net-misc/yt-dlp/yt-dlp-2022.5.18.ebuild
new file mode 100644
index 000000000000..15c3126317d0
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.5.18.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}