summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/commentjson/commentjson-0.9.0-r1.ebuild (renamed from dev-python/commentjson/commentjson-0.9.0.ebuild)17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/commentjson/commentjson-0.9.0.ebuild b/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
index cd66d386dfeb..c90432d94b96 100644
--- a/dev-python/commentjson/commentjson-0.9.0.ebuild
+++ b/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
@@ -4,31 +4,36 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Add Python and JavaScript style comments in your JSON files"
HOMEPAGE="
https://pypi.org/project/commentjson/
- https://github.com/vaidik/commentjson/"
+ https://github.com/vaidik/commentjson/
+"
SRC_URI="
https://github.com/vaidik/commentjson/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
RDEPEND="
- dev-python/lark[${PYTHON_USEDEP}]"
+ dev-python/lark[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
dev-python/six[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests unittest
src_prepare() {
- # remove unnecessary version bind
- sed -i -e '/lark-parser/s:,<0.8.0::' setup.py || die
+ # remove lark-parser dependency to allow painless upgrade to lark
+ sed -i -e '/lark-parser/d' setup.py || die
distutils-r1_src_prepare
}