summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tenacity/Manifest3
-rw-r--r--dev-python/tenacity/tenacity-8.1.0.ebuild41
-rw-r--r--dev-python/tenacity/tenacity-8.2.0.ebuild40
-rw-r--r--dev-python/tenacity/tenacity-8.2.1.ebuild40
4 files changed, 0 insertions, 124 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index b13e58d363b6..66e9b25dd5b8 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1,4 +1 @@
-DIST tenacity-8.1.0.tar.gz 37658 BLAKE2B 4f9e2ea44ac0f0ed8b694b0f60e938fadbcf65bd989e9d641f7a40750f499aa9635a70d80e406aa2ebf436ebd37cde0d88e8ecb6cb3436ba755c2d921541c8e8 SHA512 194312e80233d6edcdf30496a355b272a4de4809bbe187948a7ce9c1382958845d12401498569f2b8d4251ede2857317820779f13a65bb2e69dcb97dde9bb501
-DIST tenacity-8.2.0.tar.gz 39842 BLAKE2B 4c7b58654eff79e2b5e7412f5a920dd09df44a7699d6959dd6e1c5ee87a1e74a0c60df28239be6976368859ebabc4ab35e318a71a7ad5861d92da76a516bd721 SHA512 7bb962257200a450a5599309977c895b9e2918a195a2b60c942dad934145e85e64cf1c043e81fe1a4eb5a4a7d4eaeca626a21388297cf0983bdcea22d56553d3
-DIST tenacity-8.2.1.tar.gz 39876 BLAKE2B 5141a5ee79ee6b5664e35c06c2d95e65daf75bfcb2ea6b33418385e49f9136adde2ff99bfd8215f056f6370c7b3c2e0a755c749c164c3857c0aae4c27cc63d1b SHA512 43decc20206544165d7ad4ae67292388c45c70a126d3b1ba529529429897dafc1bf8df72a15b545a80cc1fe0eee766866e592d3f49ee6a24feddcb525dffaab8
DIST tenacity-8.2.2.tar.gz 40186 BLAKE2B af24fa209a0f9de0bb7ddd0d0979620fdb3a41967ea2d45c8864cc9feb3237d345b85015379228dd7714d7dd3f921e190bfdea3ba5c3fe627df804de6641894d SHA512 a1e2569dd5afdc982716f22ba7c67f7a43351e9f2dbefad30854d8655fa7600300c624b7353ea7d68aa462cbf2f33cf93e643e2868e8e197a61eb1ccf25c275e
diff --git a/dev-python/tenacity/tenacity-8.1.0.ebuild b/dev-python/tenacity/tenacity-8.1.0.ebuild
deleted file mode 100644
index 0ac51168196c..000000000000
--- a/dev-python/tenacity/tenacity-8.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="General-purpose retrying library"
-HOMEPAGE="
- https://github.com/jd/tenacity/
- https://pypi.org/project/tenacity/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
- )
- fi
-
- epytest
-}
diff --git a/dev-python/tenacity/tenacity-8.2.0.ebuild b/dev-python/tenacity/tenacity-8.2.0.ebuild
deleted file mode 100644
index 0bba32fca1ec..000000000000
--- a/dev-python/tenacity/tenacity-8.2.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="General-purpose retrying library"
-HOMEPAGE="
- https://github.com/jd/tenacity/
- https://pypi.org/project/tenacity/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
- )
- fi
-
- epytest
-}
diff --git a/dev-python/tenacity/tenacity-8.2.1.ebuild b/dev-python/tenacity/tenacity-8.2.1.ebuild
deleted file mode 100644
index 0bba32fca1ec..000000000000
--- a/dev-python/tenacity/tenacity-8.2.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="General-purpose retrying library"
-HOMEPAGE="
- https://github.com/jd/tenacity/
- https://pypi.org/project/tenacity/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
- )
- fi
-
- epytest
-}