summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pygresql/Manifest1
-rw-r--r--dev-python/pygresql/pygresql-5.2.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index 406b3d42e47f..1cf74e6bf189 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1 +1,2 @@
DIST PyGreSQL-5.2.4.tar.gz 270319 BLAKE2B 6ec2bf9786dd97f8649585bd00b87569d2cd668e43e8cc28443126ec2ee00943f044775b756785002c32aef516c4141e126e7d458b232bf8bfa1413bfdbd2db0 SHA512 3dbb90391e0a12f1ce4676dd5fa89d586d33a4bcb710779583beb05ae71131fbcf0412e702b542d856f3fd6ceeb145952c2f7bdede25efd08fe61ffcf0296212
+DIST PyGreSQL-5.2.5.tar.gz 272605 BLAKE2B 6b3d63ee5d34bbe4eb3f482c7a6e6ef02f6087bf8799aeabf57e2bd7bc77ba46d3d741d1f1355336df7f76f6d23c6d2894d3e3fcfbaafbe6171978c7fc4db30b SHA512 e99a9776e92d812fcf06cf3f448b38aa39ccd108b28237e22dcb663293db41c92d78aa72ad0665552dd99a6a0a8bad518521cacf0b545b888132758f36488f88
diff --git a/dev-python/pygresql/pygresql-5.2.5.ebuild b/dev-python/pygresql/pygresql-5.2.5.ebuild
new file mode 100644
index 000000000000..65d81268f5ed
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.2.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="PyGreSQL"
+POSTGRES_COMPAT=( 9.6 {10..14} )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 postgres pypi
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="https://pygresql.org/"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ postgres_pkg_setup
+ fi
+}
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage unittest || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}