summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/jmespath/Manifest1
-rw-r--r--dev-ruby/jmespath/jmespath-1.1.3.ebuild27
-rw-r--r--dev-ruby/jmespath/metadata.xml8
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/Manifest b/dev-ruby/jmespath/Manifest
new file mode 100644
index 000000000000..2d6562e675d6
--- /dev/null
+++ b/dev-ruby/jmespath/Manifest
@@ -0,0 +1 @@
+DIST jmespath-1.1.3.tar.gz 34314 SHA256 2c987327ab21bdab28b310cd3696af9cdf2e6264b0174ee40ecfd26d855c02b4 SHA512 ea76eb9fcda4cae9a874d120c81c9dc6bea0a7988287a88c9dabedc3755c9ce3ccea7a485de76d00a0e010f4f534fefa6acc99f865e370c7788b40ec10181fcf WHIRLPOOL aec4eb9fb25026e43de99da4403a12db170a9b841c5cd40d38f6a01acc4574eed9c798a57fd19c8991838d9009ccda62c701154689e8157f29e9546d3752e020
diff --git a/dev-ruby/jmespath/jmespath-1.1.3.ebuild b/dev-ruby/jmespath/jmespath-1.1.3.ebuild
new file mode 100644
index 000000000000..be1a31aa70da
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,spec_helper}.rb || die
+}
diff --git a/dev-ruby/jmespath/metadata.xml b/dev-ruby/jmespath/metadata.xml
new file mode 100644
index 000000000000..8f1ede85d22d
--- /dev/null
+++ b/dev-ruby/jmespath/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jmespath/jmespath.rb</remote-id>
+ </upstream>
+</pkgmetadata>