summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-metrics/pushgateway/pushgateway-0.10.0.ebuild1
-rw-r--r--app-metrics/pushgateway/pushgateway-0.9.1.ebuild1
-rw-r--r--app-metrics/pushgateway/pushgateway-1.0.0.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/app-metrics/pushgateway/pushgateway-0.10.0.ebuild b/app-metrics/pushgateway/pushgateway-0.10.0.ebuild
index 5ab0a518e0de..8632efe3271c 100644
--- a/app-metrics/pushgateway/pushgateway-0.10.0.ebuild
+++ b/app-metrics/pushgateway/pushgateway-0.10.0.ebuild
@@ -31,6 +31,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #672926
pushd src/${EGO_PN} || die
mkdir -p bin || die
GO111MODULE=on GOPATH="${S}" promu build -v --prefix bin || die
diff --git a/app-metrics/pushgateway/pushgateway-0.9.1.ebuild b/app-metrics/pushgateway/pushgateway-0.9.1.ebuild
index 0ec409e6c76b..3bda8444b9c4 100644
--- a/app-metrics/pushgateway/pushgateway-0.9.1.ebuild
+++ b/app-metrics/pushgateway/pushgateway-0.9.1.ebuild
@@ -31,6 +31,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #672926
pushd src/${EGO_PN} || die
mkdir -p bin || die
GO111MODULE=on GOPATH="${S}" promu build -v --prefix bin || die
diff --git a/app-metrics/pushgateway/pushgateway-1.0.0.ebuild b/app-metrics/pushgateway/pushgateway-1.0.0.ebuild
index 102cff399d1d..7a19aeed4f08 100644
--- a/app-metrics/pushgateway/pushgateway-1.0.0.ebuild
+++ b/app-metrics/pushgateway/pushgateway-1.0.0.ebuild
@@ -31,6 +31,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #672926
pushd src/${EGO_PN} || die
mkdir -p bin || die
GO111MODULE=on GOPATH="${S}" promu build -v --prefix bin || die