summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/curb/curb-0.9.11.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/curb/curb-0.9.11.ebuild b/dev-ruby/curb/curb-0.9.11.ebuild
deleted file mode 100644
index 07ac269e3ecf..000000000000
--- a/dev-ruby/curb/curb-0.9.11.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # Fix test that expects wrong output
- sed -i -e 's/200 OK /200 OK/' tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
- cp -l ext/curb_core$(get_modname) lib || die
-}