summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-runner/Manifest1
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.11.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/Manifest b/dev-python/pytest-runner/Manifest
index 805172458bcf..982e961e04a1 100644
--- a/dev-python/pytest-runner/Manifest
+++ b/dev-python/pytest-runner/Manifest
@@ -1,2 +1,3 @@
DIST pytest-runner-2.10.1.tar.gz 8815 SHA256 ecc9549ed1ce9bbfc9e7c9bad33d3f9fa91da2334632070a191a35aa96f0be35 SHA512 11c570051a0a7ff56fbb4fdc2a87185af6bbcccc05be012eeaefd775efbf21a3fb167a95ae603d627461b3775ee8cfb56b10d356044a4ae3966a7bf9f1b1f4a8 WHIRLPOOL c2a0c8a77abf5fedd31e0348a9e28ef60febbab7e4d18d7a8444fe6ca82f61c5f36b1cb183524ed9063e246cf6b8a76ca6427f3a63bba0e3c594e03e4a34fb13
+DIST pytest-runner-2.11.1.tar.gz 9661 SHA256 983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3 SHA512 5249e0a368bab21bb034a9b0121edbcda635f559cc22ba79c87565dcbc070056bfed47a69c16f4733403f61ea5b73adfd1ccf945700116043cbf3940d37d4067 WHIRLPOOL 1b233122ced9ea7bef078a3485fdb10eca6c7c1b4598114426ee7add16cb45911daa3ed72634b1d71c415166e8fa6aa2dfaf0e1fe755d0388a9efeaf28b4d097
DIST pytest-runner-2.6.2.tar.gz 6379 SHA256 e775a40ee4a3a1d45018b199c44cc20bbe7f3df2dc8882f61465bb4141c78cdb SHA512 6a993e8729d5e203986f2526d46e96b7ac19e65fc26493a55a98e858304ecde0c47576476864a0ee1817ea1a7b02cfda952fc03f79b84fff249021f140f3d00d WHIRLPOOL 968a38864b58d35d4c9fb0fa2855bae9f87bcb68936b5f129c5bc67b2c751e51bf5f9e5f54d27f36ccd6e89df7d4f8c4a6556de408cc8287f52725e1eb73fef5
diff --git a/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
new file mode 100644
index 000000000000..1717adcb2432
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( ${RDEPEND} )
+"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}