summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.6.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
index bdb93d5e0ad7..204b5fac3b18 100644
--- a/dev-python/jupyter_console/Manifest
+++ b/dev-python/jupyter_console/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_console-6.4.4.tar.gz 35145 BLAKE2B d37190c30eceba79c0d37ad60d88c9e691759aaccb29a64a9482b7c3cf3315efa3c902ac2244c2139ef2f94a77450115124227768f8291f73512796aaff1214a SHA512 1f06591ed2a0fcf56e783d4e9f2a7c3f58a4f566cfb63b3367edac23c7709aa1af7bf6639c7358227a987049804da90658144fa5ad38db120c0816e78ed465ef
DIST jupyter_console-6.5.0.tar.gz 35609 BLAKE2B 056386eaa1c214b27ff10993d08fc5351ab9f6775fa8f2882bbe8ed6ca4170edb8a8024740f3a9f0f9667c253a1945700da0e9a3bc925d970597b43c830c9e6b SHA512 9c3b44a43d0a18bbcade97fee514859b6c370941e80525630195fb6bf8fb32c3cf048dfabd2c41f7f98365d2fbd87c9e190f9fb8e899c5a29266585766df66af
DIST jupyter_console-6.5.1.tar.gz 35754 BLAKE2B 1b3e189e8a057b0f57e6a1c1409797aff9b6584edd96975c5b91a7c5d55d8601e44a3f9e0218413351d67d7175a7f6c86c3734e14ba881f6ab25ea9f1748576d SHA512 3fbd97b1ab05596ac56ba8f6038af787698197b5148f7e33a79ad5cdcc9a78c80c2534e3e2c298aeb92ce880686731b9ba206d7d0094ad67d7cd4996c02e2327
+DIST jupyter_console-6.6.0.tar.gz 19523 BLAKE2B 5fd393b2d6abaab68ce9b96632a757f6c1bd43ac192744a9ce58be1e8bcc7accc1bfdf5428c908b270a66c14014177ce559fa97a6d0da93d3bfa34af101c5c98 SHA512 e1c4d0953ffba22660d680250b3b64887ec908e0bc420caedaf9afbe0ceb4b3e8eb5ac9b5b477aadcb773867ea7fce7b7da16bb8b4e403d9cf98484271577c0b
diff --git a/dev-python/jupyter_console/jupyter_console-6.6.0.ebuild b/dev-python/jupyter_console/jupyter_console-6.6.0.ebuild
new file mode 100644
index 000000000000..7c7100a3244e
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-3.0.30[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest