summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/lxml/Manifest2
-rw-r--r--dev-python/lxml/lxml-4.4.2.ebuild82
-rw-r--r--dev-python/lxml/lxml-4.4.3.ebuild82
3 files changed, 0 insertions, 166 deletions
diff --git a/dev-python/lxml/Manifest b/dev-python/lxml/Manifest
index 60604281ff37..8355aef85e51 100644
--- a/dev-python/lxml/Manifest
+++ b/dev-python/lxml/Manifest
@@ -1,3 +1 @@
-DIST lxml-4.4.2.tar.gz 940286 BLAKE2B 28366d1673b356f980cedc64839f070e8166906705bc948af24bba369153accc0a4cea0372e87530227be88a89a0dab4d23308b75fd695f55fdb73e6326aa03b SHA512 af6608df7e47513644b841ecb6291e655122927cb439bd2ae694fd344cf5dca621e3e1ce6b40accc6db9e0c4383b5b3e6c6f9ff19f35c4daf30f119a217113ca
-DIST lxml-4.4.3.tar.gz 940482 BLAKE2B 9ece0314d7b8ef82d70e83f6b77e4abef99d486a0168497f1f97e6a93d81d58e522e259d3569373d2429ac3190a642e8d1107dbae29ca20ec56636f7576545b6 SHA512 7b07450a243595bd412a43e73a55fafda0e6a6e41ed47c5488ee8e6cbd04d48a93db1b06f8b646bdc6377cad063aa53781cf41e3048f9dd7a62ccecc20900298
DIST lxml-4.5.0.tar.gz 942013 BLAKE2B 24535fb74c58baff26c47c4bfe4ade0155044b30d099f1990c11406eca34e6bb8255631e5b30172adcf95fc61d1ab9d0384dbf9910c7694beed11cbb99595008 SHA512 b4b4692cffb7b8d074e72033711e17df2529d0747c4d086926855bb5a39478e7aea2bc195d201ca3c252822b231dbe47aaedc647e50bbd6b24754668beaa60ca
diff --git a/dev-python/lxml/lxml-4.4.2.ebuild b/dev-python/lxml/lxml-4.4.2.ebuild
deleted file mode 100644
index 70dea853ab16..000000000000
--- a/dev-python/lxml/lxml-4.4.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1 eutils toolchain-funcs
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="https://lxml.de/ https://pypi.org/project/lxml/ https://github.com/lxml/lxml"
-SRC_URI="https://github.com/lxml/lxml/archive/${P}.tar.gz"
-
-LICENSE="BSD ElementTree GPL-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads test"
-RESTRICT="!test? ( test )"
-
-# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
-RDEPEND="
- >=dev-libs/libxml2-2.9.5
- >=dev-libs/libxslt-1.1.28"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
- "
-
-DISTUTILS_IN_SOURCE_BUILD=1
-S=${WORKDIR}/lxml-${P}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5.0-cross-compile.patch
- "${FILESDIR}"/${PN}-4.4.2-tests-pypy.patch
-)
-
-python_prepare_all() {
- # avoid replacing PYTHONPATH in tests.
- sed -i -e '/sys\.path/d' test.py || die
-
- # don't use some random SDK on Darwin
- sed -i -e '/_ldflags =/s/=.*isysroot.*darwin.*None/= None/' \
- setupinfo.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- tc-export PKG_CONFIG
- distutils-r1_python_compile
-}
-
-python_test() {
- cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
- cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
- ln -s "${S}"/doc "${BUILD_DIR}"/ || die
-
- "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- local DOCS=( README.rst *.txt doc/*.txt )
- local HTML_DOCS=( doc/html/. )
- fi
- if use examples; then
- dodoc -r samples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup
- optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
-}
diff --git a/dev-python/lxml/lxml-4.4.3.ebuild b/dev-python/lxml/lxml-4.4.3.ebuild
deleted file mode 100644
index c5cc42ed9a7b..000000000000
--- a/dev-python/lxml/lxml-4.4.3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1 eutils toolchain-funcs
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="https://lxml.de/ https://pypi.org/project/lxml/ https://github.com/lxml/lxml"
-SRC_URI="https://github.com/lxml/lxml/archive/${P}.tar.gz"
-S=${WORKDIR}/lxml-${P}
-
-LICENSE="BSD ElementTree GPL-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads test"
-RESTRICT="!test? ( test )"
-
-# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
-RDEPEND="
- >=dev-libs/libxml2-2.9.5
- >=dev-libs/libxslt-1.1.28"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
- "
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5.0-cross-compile.patch
- "${FILESDIR}"/${PN}-4.4.2-tests-pypy.patch
-)
-
-python_prepare_all() {
- # avoid replacing PYTHONPATH in tests.
- sed -i -e '/sys\.path/d' test.py || die
-
- # don't use some random SDK on Darwin
- sed -i -e '/_ldflags =/s/=.*isysroot.*darwin.*None/= None/' \
- setupinfo.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- tc-export PKG_CONFIG
- distutils-r1_python_compile
-}
-
-python_test() {
- cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
- cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
- ln -s "${S}"/doc "${BUILD_DIR}"/ || die
-
- "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- local DOCS=( README.rst *.txt doc/*.txt )
- local HTML_DOCS=( doc/html/. )
- fi
- if use examples; then
- dodoc -r samples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup
- optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
-}