summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/concurrent-ruby/Manifest1
-rw-r--r--dev-ruby/concurrent-ruby/concurrent-ruby-1.0.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/concurrent-ruby/Manifest b/dev-ruby/concurrent-ruby/Manifest
index e2e4eb70505b..70ceac9186c2 100644
--- a/dev-ruby/concurrent-ruby/Manifest
+++ b/dev-ruby/concurrent-ruby/Manifest
@@ -1,2 +1,3 @@
DIST concurrent-ruby-1.0.0.tar.gz 1269980 SHA256 21a5942bd18d6ca2bdf547f16925f167b0c18592f737091ea5531f07de92fba0 SHA512 5b2a6b5d0e43d1df768d9e18328ecee04796af70edaa72646431e0c4e2ff75387542cce8f78b69d73514166348ed73f906f00bd6e627969159ab1ce4e2a75e6c WHIRLPOOL c7875df7f5c3f91487c1a85a46948225ccfebeb625ae1d4c6fd5b87ba7f224bc50aeb782a58bcfd6f5423d52dea7a54ef57189ae0bc4a23b5996e0b9b41feede
DIST concurrent-ruby-1.0.1.tar.gz 1277569 SHA256 696c1f8044f072512d512b48c21e9c66ec4e970706cdbb8fa90e0fab5a4ea254 SHA512 14dfdad55701fcdf6ac97e87ac9ee4113340d8f2a01eb1970b2635b175a34d04c9f208d2ed445dfd8d28f67acb5cd8b6e2e89ace86bccff8c8728ee69eb0f87a WHIRLPOOL 5166bd500deeab934e97ff9c560e6d56d37113201436f528a63a57af91cc9cbb2e4ff5f45397fd77ff01db8b4eb816ec4678cf8f404e09cfd740e79dbffdf929
+DIST concurrent-ruby-1.0.2.tar.gz 1278198 SHA256 a8051789e6b08448ae350031cf13ec563b0a176651b7d81d9f9e845b9b126ff4 SHA512 ad82af8bb5a6aeb6133466580e3e6b51cc37dcc9391b0bbfdc5230ac761453747fcac1b080a09772c90d7a05047ae4ac0ba4113fbd048c4b3c3712064b7a22d9 WHIRLPOOL 55a8d668cad46f357d3b54428f0ab42b349f46b5e9a785cf053944ef96a4f0267b775911b7cec5d6d64bc40fb7efc1f1cc0ef5affdc7307ea5e40db8af6dc87c
diff --git a/dev-ruby/concurrent-ruby/concurrent-ruby-1.0.2.ebuild b/dev-ruby/concurrent-ruby/concurrent-ruby-1.0.2.ebuild
new file mode 100644
index 000000000000..95d58e94bc8a
--- /dev/null
+++ b/dev-ruby/concurrent-ruby/concurrent-ruby-1.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Modern concurrency tools including agents, futures, promises, thread pools, more"
+HOMEPAGE="https://github.com/ruby-concurrency/concurrent-ruby"
+SRC_URI="https://github.com/ruby-concurrency/concurrent-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove edge files as defined in support/file_map.rb
+ rm -rf {lib,spec}/concurrent/{actor,channel,edge}* \
+ lib/concurrent/{concurrent-edge,lazy_register.rb} \
+ spec/concurrent/lazy_register_spec.rb || die
+ sed -i -e '/concurrent-edge/ s:^:#:' spec/spec_helper.rb || die
+
+ # Remove specs for the ext gem
+ rm -rf spec/concurrent/atomic || die
+
+ sed -i -e '/file_map/d' -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}