summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/legion/Manifest1
-rw-r--r--sys-cluster/legion/legion-18.05.0.ebuild4
-rw-r--r--sys-cluster/legion/legion-18.12.0.ebuild40
-rw-r--r--sys-cluster/legion/legion-9999.ebuild7
-rw-r--r--sys-cluster/legion/metadata.xml4
5 files changed, 47 insertions, 9 deletions
diff --git a/sys-cluster/legion/Manifest b/sys-cluster/legion/Manifest
index 1d9bd405d1ba..f7e70db3ed27 100644
--- a/sys-cluster/legion/Manifest
+++ b/sys-cluster/legion/Manifest
@@ -6,3 +6,4 @@ DIST legion-17.08.0.tar.gz 2839522 BLAKE2B b9f9d814b319c69a1e29b108c7d78fcd04f87
DIST legion-17.10.0.tar.gz 2975023 BLAKE2B 772f666c0cd8fc96e1e460e4c8253289069eea2ed8820f091ad517228fb7b2d56bc8bedbe9bc4d5776869fc4f0250f71644bf773362f65a0bba6f96be51c32af SHA512 c4be9b32b47b3c4ae38374606125867f963a109dd542a52ee20b2964e5849121207d78947f0ab6ea4ed5e8a027b26da7b1a3a61124f175c1b9f7323e56b8d9b2
DIST legion-18.02.0.tar.gz 2967232 BLAKE2B 5f22efe681ee036af95b3d84c104988acfea899b76684860c1a27dda27b757c7a444ea5c1cec70ce0a19ffaa8323c208997402971017f72415a12ff9aabadea5 SHA512 052026c6f7e3920bfe097ada83571e4f7d4ad74a59d4a84af4d35f089c5d1b216e90f4f8547ea894e4b53b138b81e594c60342c41557c985b64d08c4aca23794
DIST legion-18.05.0.tar.gz 3009091 BLAKE2B 86c113cad11e2fbdcf03233c09fe429ceff12aaac6621e0ae22ac141cf7a6c62f7df23f78861a826ba55a45c3eae46ca60b9e47339f9ed3333560797733b7d4e SHA512 f7000b5a6b66d07d72de9be7ef0bcdfd7aa95f838bfc1ccb4b146cf0c4407682a5cde75b56311bb07abd808dc67527e02a3a3db10bca874028a7335b54e1120a
+DIST legion-18.12.0.tar.gz 3138868 BLAKE2B c85faf51eb528085f05a5e3411253f0ceb4ef6c6252466861d5641bd2df8320738d3cfd864781c05986038ed84cb6bec95d889f3d4d1ef8b25d90f2d339a9300 SHA512 26fc5d0fe1743de3e634fa3c2d95c3758b21bba7a1e1eb66c4c69d43d0d557b595b691b1bcd091f2c23ea034f000491ea6d5d81da94fb531781462e3093a202d
diff --git a/sys-cluster/legion/legion-18.05.0.ebuild b/sys-cluster/legion/legion-18.05.0.ebuild
index 51357e884176..c52bb9263a68 100644
--- a/sys-cluster/legion/legion-18.05.0.ebuild
+++ b/sys-cluster/legion/legion-18.05.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,7 +23,7 @@ IUSE="gasnet +hwloc test"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( <sys-apps/hwloc-2 )
"
src_configure() {
diff --git a/sys-cluster/legion/legion-18.12.0.ebuild b/sys-cluster/legion/legion-18.12.0.ebuild
new file mode 100644
index 000000000000..c52bb9263a68
--- /dev/null
+++ b/sys-cluster/legion/legion-18.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc test"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( <sys-apps/hwloc-2 )
+ "
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index 443814e2abdd..c52bb9263a68 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,17 +19,18 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="gasnet +hwloc"
+IUSE="gasnet +hwloc test"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( <sys-apps/hwloc-2 )
"
src_configure() {
mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
-DBUILD_SHARED_LIBS=ON
-DLegion_BUILD_EXAMPLES=ON
-DLegion_BUILD_TESTS=ON
diff --git a/sys-cluster/legion/metadata.xml b/sys-cluster/legion/metadata.xml
index 15e1c0385f6f..54d1cf1a5f0d 100644
--- a/sys-cluster/legion/metadata.xml
+++ b/sys-cluster/legion/metadata.xml
@@ -1,10 +1,6 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
<maintainer type="project">
<email>cluster@gentoo.org</email>
<name>Gentoo Cluster Project</name>