summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/base/package.use.force2
-rw-r--r--www-client/chromium/chromium-55.0.2853.0.ebuild6
2 files changed, 3 insertions, 5 deletions
diff --git a/profiles/base/package.use.force b/profiles/base/package.use.force
index f8dce28e7fad..1189166f64ec 100644
--- a/profiles/base/package.use.force
+++ b/profiles/base/package.use.force
@@ -4,7 +4,7 @@
# Pawel Hajdan jr <phajdan.jr@gentoo.org> (20 Aug 2016)
# Chromium GYP build is no longer supported - always use GN.
->=www-client/chromium-54 gn gnome gnome-keyring
+>=www-client/chromium-54 gn
# Michael Palimaka <kensington@gentoo.org> (27 Jul 2016)
# Reverse dependencies need to be fully investigated yet
diff --git a/www-client/chromium/chromium-55.0.2853.0.ebuild b/www-client/chromium/chromium-55.0.2853.0.ebuild
index dfc66363ca2c..a0ce5d74eb8c 100644
--- a/www-client/chromium/chromium-55.0.2853.0.ebuild
+++ b/www-client/chromium/chromium-55.0.2853.0.ebuild
@@ -18,11 +18,9 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="cups +gn +gnome +gnome-keyring gtk3 +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +tcmalloc widevine"
+IUSE="cups +gn gnome gnome-keyring gtk3 +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
-REQUIRED_USE="gn? ( gnome gnome-keyring )"
-
# Native Client binaries are compiled with different set of flags, bug #452066.
QA_FLAGS_IGNORED=".*\.nexe"
@@ -407,11 +405,11 @@ src_configure() {
$(gyp_use tcmalloc use_allocator tcmalloc none)
$(gyp_use widevine enable_widevine)"
- # TODO: support USE=gnome-keyring for GN
myconf_gn+=" enable_hangout_services_extension=$(usex hangouts true false)"
myconf_gn+=" enable_widevine=$(usex widevine true false)"
myconf_gn+=" use_cups=$(usex cups true false)"
myconf_gn+=" use_gconf=$(usex gnome true false)"
+ myconf_gn+=" use_gnome_keyring=$(usex gnome-keyring true false)"
myconf_gn+=" use_gtk3=$(usex gtk3 true false)"
myconf_gn+=" use_kerberos=$(usex kerberos true false)"
myconf_gn+=" use_pulseaudio=$(usex pulseaudio true false)"