summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/routino/Manifest1
-rw-r--r--sci-geosciences/routino/routino-3.3.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index 8bcf4f334056..b5e887f673e6 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1 +1,2 @@
DIST routino-3.3.2.tgz 2542029 BLAKE2B e74af857ef29d4ee4a08d8a2913180dfca747001f4afd59ad20a9ed355e654dc86d26fb1afb5486ece30ddf6b7cba7b60c52feae30af14086f2b4d5259451125 SHA512 5341a2ec063192754d641a4543260f4b3b3d84a7a9bfe745fca2082cdcc8bb7220bf37ed58aacf9e65eba4555432a6bdbb9747153a383dfff72e2aca01c66070
+DIST routino-3.3.3.tgz 2564198 BLAKE2B 0476e4afb2279c6a93b3d5192a1be580b0ee20fe07b5101c7d590bd3b74873e0205549c2fa621c6444eea0dd0cf0545c9fc054454e04f434d3e57ed750b1df3d SHA512 b037f6ef38b3abef4639d639c3564b42adc742d225108905d0cacb790e4a07593245c537b5550c43874cd6083f37b710b7aec02a0b0669c927804cf30ce34386
diff --git a/sci-geosciences/routino/routino-3.3.3.ebuild b/sci-geosciences/routino/routino-3.3.3.ebuild
new file mode 100644
index 000000000000..7a46ac85f347
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.3.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="https://routino.org/"
+SRC_URI="https://routino.org/download/${P}.tgz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig
+ )
+"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.2.patch )
+
+src_prepare() {
+ default
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+}
+
+src_compile() {
+ emake -j1
+ rm README.txt || die "rm README.txt failed"
+ mv doc/README.txt . || die "mv doc/README.txt . failed"
+ if use python; then
+ pushd python > /dev/null
+ python_compile() {
+ rm -f build/.timestamp || die
+ emake PYTHON=${EPYTHON}
+ }
+ python_foreach_impl python_compile
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ emake test
+# if use python; then
+# pushd python > /dev/null
+# python_test() {
+# echo "######## ${EPYTHON} ########"
+# emake PYTHON=${EPYTHON} test
+# }
+# python_foreach_impl python_test
+# popd > /dev/null
+# fi
+}
+
+src_install() {
+ default
+ if use python; then
+ pushd python > /dev/null
+ python_install() {
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl python_install
+ newdoc README.txt README_python.txt
+ popd > /dev/null
+ fi
+
+}