summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/capistrano/Manifest1
-rw-r--r--dev-ruby/capistrano/capistrano-3.11.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/Manifest b/dev-ruby/capistrano/Manifest
index 122a28af4088..b0a2729d7e28 100644
--- a/dev-ruby/capistrano/Manifest
+++ b/dev-ruby/capistrano/Manifest
@@ -1,3 +1,4 @@
DIST capistrano-2.15.5.gem 132096 BLAKE2B bbaa6bd482cf9bbe7aa01540aa5dab3f32401ffa1476d9057bb8ad420194f1ab2c32d8e744d7c982ebece5c4b5369133dc8378b7adf54c78732f9cb249db2a9e SHA512 10168080c7481ec6fc6f918ac90a3b1ce8f2b36f77411375e33cc915b02d5196ab061ac47e767edd724c82cffd1c2ad0a23ba1f0519cf1f2aae5b429167b19ff
DIST capistrano-3.10.1.gem 77824 BLAKE2B 548c86c0740703a5b0b92890806411221ea7a9942776d88fc999ce998e3cf5842d809e293d05111ce44cb849719900c7335c43d3795d7147688d48d53a19a133 SHA512 6f3f11498d26c426da740873022767ded44e1be1aeadddd01772d1a5c43dcf2589d5cf2279625470e2e2733d60d3ec865a39640ad4a14b2ef9a64b3da2da579b
DIST capistrano-3.10.2.gem 78336 BLAKE2B 782cf09f810fd91f4878e126c12d57d19b75c1ccdf3dfee7b2078904743bf51047d1f948e64e6c41460fdaf0a3a9e5a2b646bd6a797f8ce97bc29fab9ca9c533 SHA512 a7eadcd0b949baab2d6ad09c2243f71ec803f85b5c3cf455068d3b0889be30d0f6bbee4ef0bdf90b9c7ec6c3e01886d350fd8a70824366383f7dcc49f0a8c92e
+DIST capistrano-3.11.0.gem 78336 BLAKE2B f4e3ac2c796aae12ca575e1b5f1e42d993ad13580d790c3cc392322c40486121d8dbd7bf0f0fa75c3ee59396c0dd91164b2112d30b4270b302a9f1556fe866bb SHA512 d8b635de223a0574c17dff6fdfe4007741f823e24f376cc22129b709d40792d02965b72465aeeb54560f22522dafe255f094bde9a23aa259bca9d4933585e212
diff --git a/dev-ruby/capistrano/capistrano-3.11.0.ebuild b/dev-ruby/capistrano/capistrano-3.11.0.ebuild
new file mode 100644
index 000000000000..9e9844d807ec
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.11.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="https://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+
+ # Avoid specs that require a TTY
+ sed -i -e '/asking for a variable/,/^ end/ s:^:#:' spec/integration/dsl_spec.rb || die
+ rm -f spec/lib/capistrano/configuration/question_spec.rb || die
+}