summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/cabextract/Manifest1
-rw-r--r--app-arch/cabextract/cabextract-1.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/cabextract/Manifest b/app-arch/cabextract/Manifest
index f019850002ca..58b2879374b5 100644
--- a/app-arch/cabextract/Manifest
+++ b/app-arch/cabextract/Manifest
@@ -1,2 +1,3 @@
DIST cabextract-1.6.tar.gz 241731 BLAKE2B 49a94b1b0d8a6c9f61cd51280a035e3fedb8d7a2d097b132bc56114c6003a558647a7f8c47b8d08fcac1999e68bea5303adb2b03c8e6dd010995e8b0c6dcd442 SHA512 d1c71c0292e3d73d8edbff5f5230b3127c63028f5aba1d0cad968bc945202fb9c0773327affce3d28466068377f029c80735adbabe0929d29b2204dea73738f8
DIST cabextract-1.7.tar.gz 293760 BLAKE2B d5ab4783c944d5d8b1d9ed8a2fbbfd60aeeab9f12b836032f982efc5721055b2caa521147246b3b5274d9456b1dbd2d513455cfd57750cf6d7fdc18f109f96c9 SHA512 63789e485d57299f2a0a60dc6d9a94e83639eb59b73789eff52977d3d3bd37a1c00713c86a4c6289e35541d0b7240ea0545ba84013713c070b4324ae1f2865ce
+DIST cabextract-1.8.tar.gz 289256 BLAKE2B ba9fea0cd12859b0de97b13362eaf276066650eb7151e0115af7ed2586cfa7497f72be2f9287d3ccb5ce5256ec26ca69e729df5bb0a327bb9f32ded25391460c SHA512 f8d676d6b738b0b13ac1cac7716c2fb46db423ef30b05ee64f00fcb19596131fbd34341c8b417af3de04896e9b6a8abf0d5976ee4bf87d016806a71317246d7a
diff --git a/app-arch/cabextract/cabextract-1.8.ebuild b/app-arch/cabextract/cabextract-1.8.ebuild
new file mode 100644
index 000000000000..5990d8ff13fe
--- /dev/null
+++ b/app-arch/cabextract/cabextract-1.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extracts files from Microsoft cabinet archive files"
+HOMEPAGE="https://www.cabextract.org.uk/"
+SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="extras"
+
+RDEPEND="extras? ( dev-lang/perl )"
+
+src_prepare() {
+ default
+ # the code attempts to set up a fnmatch replacement, but then fails to code
+ # it properly leading to undefined references to rpl_fnmatch(). This may be
+ # removed in the future if building still works by setting "yes" to "no".
+ export ac_cv_func_fnmatch_works=yes
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic )
+ default
+ docinto html
+ dodoc doc/wince_cab_format.html
+ if use extras; then
+ dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
+ fi
+}