summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2023.07.06.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 49b631eb196e..ecc8a5f2d608 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,3 +1,4 @@
DIST yt-dlp-2023.03.04.tar.gz 5125843 BLAKE2B 8c2a610b98e83b6aa4b4daaaaaaf805a2e780a38af21168a90f305196f14716df5830235a600278158a7e3a758e3a5daf56e88cbaa38f4675b52a7bfbfdb1dd2 SHA512 3220ad0d7445351e5786b5ff1634b633a601f64216813129056d0c8470ce8afa2e6df6d402a9381980df6611e9341039cb7f576dfd444b05fbb1417ba1aced52
DIST yt-dlp-2023.06.21.tar.gz 5320227 BLAKE2B c7a48345623a1ef1419c3eb3d762c03ec960ae386751c317425c0e13e123f4afd23e8ea6aeca70741026ee9ea716f819641768c84da5a2e963d0863b4eaf14fe SHA512 6073e37df7bc080cfb74192ba3af1912ff73e8689e321a1e9156e9c23f80fe2a4fbb956da2a9df60ad147bbadf19d185e5eab892b8634a7fd5d907dc675c238a
DIST yt-dlp-2023.06.22.tar.gz 5341212 BLAKE2B 90595785894cc8c3e8da163ae830afb72f0cc19c306ddfa8fa4a9dbfcd897dae540d01039e05b4232f135e32af736dfe34256eb767f5c90da7e995b230049b3b SHA512 0755f2104f71ff5cecba5007ebb351cf9426b4cc47579c6f3a9d8954c7ead9727df159c307e3338f0b49a8d458011b94cadde53afa77ff372517de814da9dfcb
+DIST yt-dlp-2023.07.06.tar.gz 5362006 BLAKE2B a1675bf6fc41a4a4fb90401a50cc0dc7e84d4d751aed7ee9520d04fba8060f6c877a13d9a9e07ce8f36ffb2053f6048d54eaa5628d97c41457b36b965127d342 SHA512 f9f276ccd01293d27a749575653449d73e13896c175a51f3687b2f6d1c6b97154f6c9fb2868f0c37a6e94cb692e223c7c595e741c5b2db82d2b9e1d0b2f8958d
diff --git a/net-misc/yt-dlp/yt-dlp-2023.07.06.ebuild b/net-misc/yt-dlp/yt-dlp-2023.07.06.ebuild
new file mode 100644
index 000000000000..77c77e61186a
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2023.07.06.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}