summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild27
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild27
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild b/sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild
new file mode 100644
index 000000000000..001c620bda93
--- /dev/null
+++ b/sys-cluster/openstack-meta/openstack-meta-2019.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+ keystone? ( ~sys-auth/keystone-16.0.0 )
+ swift? ( ~sys-cluster/swift-2.23.0 )
+ neutron? ( ~sys-cluster/neutron-15.0.0 )
+ glance? ( ~app-admin/glance-19.0.0 )
+ cinder? ( ~sys-cluster/cinder-15.0.0 )
+ nova? ( ~sys-cluster/nova-20.0.0 )
+ heat? ( ~sys-cluster/heat-13.0.0 )
+ placement? ( ~sys-cluster/placement-2.0.0 )
+"
diff --git a/sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild b/sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild
new file mode 100644
index 000000000000..b17a0a59978d
--- /dev/null
+++ b/sys-cluster/openstack-meta/openstack-meta-2019.2.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+ keystone? ( ~sys-auth/keystone-${PV} )
+ swift? ( ~sys-cluster/swift-${PV} )
+ neutron? ( ~sys-cluster/neutron-${PV} )
+ glance? ( ~app-admin/glance-${PV} )
+ cinder? ( ~sys-cluster/cinder-${PV} )
+ nova? ( ~sys-cluster/nova-${PV} )
+ heat? ( ~sys-cluster/heat-${PV} )
+ placement? ( ~sys-cluster/placement-${PV} )
+"