summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/magic_enum/Manifest1
-rw-r--r--dev-cpp/magic_enum/magic_enum-0.8.2.ebuild28
-rw-r--r--dev-cpp/magic_enum/metadata.xml11
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/magic_enum/Manifest b/dev-cpp/magic_enum/Manifest
new file mode 100644
index 000000000000..f363ac357209
--- /dev/null
+++ b/dev-cpp/magic_enum/Manifest
@@ -0,0 +1 @@
+DIST magic_enum-0.8.2.tar.gz 171915 BLAKE2B e8915aa7cafa9407d5d4ab3b6837fafde6b1cb75877c8b56f82568e6291ca317720950947b2dfc7e12ca459279ba4e809a8c5782fc04adc2d7636eddcb80122d SHA512 849c426484156faf91dde3f32f6c755c7698879b16dd83e13fb86b299b53ec9bbe4d55267581386302c8acb93d80ec044cc248371fdc8608cdd8f4ab12099f0a
diff --git a/dev-cpp/magic_enum/magic_enum-0.8.2.ebuild b/dev-cpp/magic_enum/magic_enum-0.8.2.ebuild
new file mode 100644
index 000000000000..df1937ee496b
--- /dev/null
+++ b/dev-cpp/magic_enum/magic_enum-0.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# As of 0.8.2, it has meson, but only for subproject use(?)
+# Doesn't install anything.
+inherit cmake
+
+DESCRIPTION="Static reflection for enums in header-only C++"
+HOMEPAGE="https://github.com/Neargye/magic_enum"
+SRC_URI="https://github.com/Neargye/magic_enum/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# Tests fail to compile
+RESTRICT="!test? ( test ) test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAGIC_ENUM_OPT_BUILD_TESTS=$(usex test)
+ -DMAGIC_ENUM_OPT_INSTALL=ON
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/magic_enum/metadata.xml b/dev-cpp/magic_enum/metadata.xml
new file mode 100644
index 000000000000..9c4b1d48036d
--- /dev/null
+++ b/dev-cpp/magic_enum/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Neargye/magic_enum</remote-id>
+ </upstream>
+</pkgmetadata>